Error in processing GCP or EXIF

Good morning from Australia,
This is the first time I have used GCP’s and am getting the error below…after 7 hours processing.

There are 1071 images and 8 GCPs to process, with a minimum of 3 images/GCP. Most GCP’s have 5 images. EPSG used is: 28354 being MGA94 zone 54.

Is there anything you could point me to from the error below without having to load all the images to Dropbox or other?


Finalizing texture atlases… done. (Took: 0.722s) Building objmodel:

Saving model… done.

Whole texturing procedure took: 163.28s

[INFO] Finished mvs_texturing stage

[INFO] Running odm_georeferencing stage

100 - done.

Traceback (most recent call last):

File “/code/”, line 54, in retcode = app.execute() File “/code/stages/”, line 130, in execute raise e File “/code/stages/”, line 94, in execute

File “/code/opendm/”, line 340, in run

File “/code/opendm/”, line 340, in run

File “/code/opendm/”, line 340, in run

[Previous line repeated 5 more times]

File “/code/opendm/”, line 321, in run self.process(self.args, outputs) File “/code/stages/”, line 30, in process gcps = octx.ground_control_points(reconstruction.georef.proj4())

File “/code/opendm/”, line 462, in ground_control_points gcps = ds.load_ground_control_points() File “/code/SuperBuild/install/bin/opensfm/opensfm/”, line 969, in load_ground_control_points return self.load_ground_control_points_impl(reference)

File “/code/SuperBuild/install/bin/opensfm/opensfm/”, line 981, in load_ground_control_points_impl exif = {image: self.load_exif(image) for image in self.images()} File “/code/SuperBuild/install/bin/opensfm/opensfm/”, line 981, in exif = {image: self.load_exif(image) for image in self.images()} File “/code/SuperBuild/install/bin/opensfm/opensfm/”, line 579, in load_exif with self.io_handler.open_rt(self._exif_file(image)) as fin:

*File “/code/SuperBuild/install/bin/opensfm/opensfm/”, line 1349, in open_rt return, “r”, encoding=“utf-8”) File “/code/SuperBuild/install/bin/opensfm/opensfm/”, line 1341, in open return open(*args, *kwargs)

FileNotFoundError: [Errno 2] No such file or directory: ‘/var/www/data/e852b60f-abdf-47fc-a95d-d967f81b510b/opensfm/exif/DJI_0567.JPG.exif’

1 Like

Ah, thanks for the report! This is a bug that was mistakenly introduced with Embed GCP information in outputs by pierotofy · Pull Request #1318 · OpenDroneMap/ODM · GitHub :pray:

Fix available on Fix EXIF error while using GCPs by pierotofy · Pull Request #1321 · OpenDroneMap/ODM · GitHub, will be available shortly.


Thanks very much for your swift response.

The joys of software development. Thanks for all your doing.



I’ve run again and turned off the ‘Optimize Disk Space’ switch and it failed again. I had a look at the console output and switch was still on. I am using Firefox as my browser and wondered if there was a problem parsing this through to the final command?


1 Like

Nah, browser shouldn’t affect option parsing. Seems like it is on our end and will need to wait for things to be updated here shortly.

Ahh, sorry i thought it was a simple as turning off the switch in the browser.

1 Like

Yeah, it normally would be, but I think we’re having an issue on our end. You can try another browser, but I don’t expect it to make a difference at this point.

Update is out; please try to re-process and see if the issue persists? :pray:

1 Like

Thanks guys, it did complete this time but I’m not sure if the result is due to an error in my switches or not. See the image below showing the resulting orthophoto has only small specks.

Could you post your processing parameters and maybe one or two representative images?

No worries, below is the output showing parameters and a random image. it would only let upload one image

[INFO] DTM is turned on, automatically turning on point cloud classification
[INFO] Initializing ODM - Sat Aug 07 02:07:23 2021
[INFO] ==============
[INFO] build_overviews: False
[INFO] camera_lens: auto
[INFO] cameras: {}
[INFO] cog: False
[INFO] copy_to: None
[INFO] crop: 3
[INFO] debug: False
[INFO] dem_decimation: 1
[INFO] dem_euclidean_map: False
[INFO] dem_gapfill_steps: 3
[INFO] dem_resolution: 2.0
[INFO] depthmap_resolution: 640
[INFO] dsm: True
[INFO] dtm: True
[INFO] end_with: odm_postprocess
[INFO] fast_orthophoto: False
[INFO] feature_quality: high
[INFO] feature_type: sift
[INFO] force_gps: False
[INFO] gcp: /var/www/data/3c1f9b3b-099a-4f4f-85f8-9a42de94bbc5/gcp/gcp_list.txt
[INFO] geo: None
[INFO] gps_accuracy: 10
[INFO] ignore_gsd: False
[INFO] matcher_distance: 0
[INFO] matcher_neighbors: 8
[INFO] matcher_type: flann
[INFO] max_concurrency: 24
[INFO] merge: all
[INFO] mesh_octree_depth: 11
[INFO] mesh_size: 200000
[INFO] min_num_features: 8000
[INFO] name: 3c1f9b3b-099a-4f4f-85f8-9a42de94bbc5
[INFO] optimize_disk_space: True
[INFO] orthophoto_compression: DEFLATE
[INFO] orthophoto_cutline: False
[INFO] orthophoto_kmz: False
[INFO] orthophoto_no_tiled: False
[INFO] orthophoto_png: False
[INFO] orthophoto_resolution: 2.0
[INFO] pc_classify: True
[INFO] pc_csv: False
[INFO] pc_ept: False
[INFO] pc_filter: 2.5
[INFO] pc_geometric: False
[INFO] pc_las: False
[INFO] pc_quality: medium
[INFO] pc_rectify: False
[INFO] pc_sample: 0.01
[INFO] pc_tile: False
[INFO] primary_band: auto
[INFO] project_path: /var/www/data
[INFO] radiometric_calibration: none
[INFO] rerun: None
[INFO] rerun_all: False
[INFO] rerun_from: None
[INFO] resize_to: 2048
[INFO] skip_3dmodel: False
[INFO] skip_band_alignment: False
[INFO] skip_report: False
[INFO] sm_cluster: None
[INFO] smrf_scalar: 1.25
[INFO] smrf_slope: 0.15
[INFO] smrf_threshold: 0.5
[INFO] smrf_window: 18.0
[INFO] split: 999999
[INFO] split_image_groups: None
[INFO] split_overlap: 150
[INFO] texturing_data_term: gmi
[INFO] texturing_keep_unseen_faces: False
[INFO] texturing_outlier_removal_type: gauss_clamping
[INFO] texturing_skip_global_seam_leveling: False
[INFO] texturing_skip_local_seam_leveling: False
[INFO] texturing_tone_mapping: none
[INFO] tiles: False
[INFO] time: False
[INFO] use_3dmesh: False
[INFO] use_exif: False
[INFO] use_fixed_camera_params: False
[INFO] use_hybrid_bundle_adjustment: False
[INFO] verbose: False

What are you displaying the Orthophoto in?

I’ve checked QGIS, irfanView and ER Viewer. All the same

1 Like

Mm, very strange.

I would try to process a subset of the images; perhaps some images are throwing off the reconstruction. Also does it reconstruct correctly without GCPs? If so, perhaps an error in the GCP file is likely.

1 Like

I ran a flight from another area with GCP’s and it worked fine. I’ll check the GCP’s and run again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.