Error in processing Dataset "ReconstructMesh"

Hi folks

While Processing a rather small dataset with 100 pictures i get the following error:

[ERROR] Failed to open file:
[INFO] running “G:\WebODM\resources\app\apps\ODM\SuperBuild\install\bin\OpenMVS\ReconstructMesh” -i “G:\WebODM\resources\app\apps\NodeODM\data\65c67acf-33f3-4a5c-8f88-47af5252a8bf\odm_meshing\odm_mesh.dirty.ply” -o “G:\WebODM\resources\app\apps\NodeODM\data\65c67acf-33f3-4a5c-8f88-47af5252a8bf\odm_meshing\odm_mesh.ply” --remove-spikes 0 --remove-spurious 0 --smooth 0 --target-face-num 400000
===== Dumping Info for Geeks (developers need this to fix bugs) =====
Child returned 1
===== Done, human-readable information to follow… =====

[ERROR] Uh oh! Processing stopped because of strange values in the reconstruction. This is often a sign that the input data has some issues or the software cannot deal with it. Have you followed best practices for data acquisition? See
Traceback (most recent call last):
File “G:\WebODM\resources\app\apps\ODM\stages\”, line 83, in execute
File “G:\WebODM\resources\app\apps\ODM\opendm\”, line 338, in run
File “G:\WebODM\resources\app\apps\ODM\opendm\”, line 338, in run
File “G:\WebODM\resources\app\apps\ODM\opendm\”, line 338, in run
[Previous line repeated 3 more times]
File “G:\WebODM\resources\app\apps\ODM\opendm\”, line 319, in run
self.process(self.args, outputs)
File “G:\WebODM\resources\app\apps\ODM\stages\”, line 24, in process
File “G:\WebODM\resources\app\apps\ODM\opendm\”, line 178, in screened_poisson_reconstruction’"{reconstructmesh}" -i “{infile}” ’
File “G:\WebODM\resources\app\apps\ODM\opendm\”, line 90, in run
raise SubprocessException(“Child returned {}”.format(retcode), retcode)
opendm.system.SubprocessException: Child returned 1

This problem occurs on our old server, that shall in the future process our Orthophoto-Datasets. It hast two Xeon E5-2650 processors with 32 logical processors and 128 GB RAM.

On my normal workstation everything works perfectly fine with the same images. It seems to me, the software cant open something called “ReconstructMesh”.

Reinstallation did not help, unfortunately.

I’m running the “native” webODM-Install on both machines.

I would be happy, if you can help,
greetings, Max

1 Like


Sorry to read you’re having trouble.

What version of WebODM for Windows (native) are you currently running?

What Operating System is on that server?

The Server is running on Win10Pro (was an old SBS2011, but for Orthophoto-processing win10 is sufficient for us).

WebODM ist 1.9.0 build 9

1 Like

So I just tried it with fast orthophoto, same error.

I checked for updates and am at the moment installing the newest version, will try again and come back later

1 Like

After the update it works. I could have had that idea earlier…

Thanks anyway for the help, and sorry for the unnecessary post.

grat community here, have been reading for a while now :slight_smile:


All good! Glad you’re up and running.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.