Error in development environment : chmod: cannot access ▒/webodm/*.sh▒: No such file or directory

Currently running WebODM in Windows 10 with Docker with 6gb RAM. Due to power failure, my laptop got shut down and since then I have been receiving this error. I tried to run WebODM without development environment by ./ start which works fine and the WebODM can start. But when I try ./ start this error shows up. I also removed all and started from a clean branch for development environment but this error still persists. Any suggestion what should I do…?


Mm, ./ restart?

./ restart works. WebODM starts without any error. But if I switch back to ./ start the same error occurs.

./ restart

./ start

Mm, I would try to stop and remove all containers, delete all volumes and relaunch the command. Also check that the directory from which you are running ./ is not corrupted and that all *.sh files are there.

Tried all. Still, no solution :disappointed_relieved: Just can’t figure out why this is happening, normal mode it is working fine but switching to development mode is not working :sweat:
As far as I understand both use the same file to start right.?

The only difference is that the development environment mounts the /webodm directory in the container from the directory where you launch WebODM.


Unfortunately I’ve never seen this error before. It’s related to docker. Try googling.

Uninstalling Docker and reinstalling it again worked. On fresh install I again enabled the option for drive sharing inside docker settings and allowed the connection under firewall settings.
Thanks for suggestion :grinning:

The problem was I guess as you mentioned with mounting. Although previously as I checked in docker settings the drive were checked for sharing but may be firewall was blocking them which I had not checked. May be due to power failure something went wrong and firewall starting blocking them again.

So solution to this would be

  1. Check if the drive is selected for sharing. If yes then check if firewall in not blocking the connection.
  2. Or try to uncheck the shared drive and select again.
  3. Last option uninstall and install docker again.

Allow connection in firewall under Inbound Rule for 445 TCP and UDP