Error durring submodel processing. Precisely in fused depthmap step. "Child returned 3221226505"

The issue happen durring submodel opensfm processing step, in fused depthmap stage. Child returned 3221226505

1 Like

Welcome! Sorry for the trouble.

Could you please provide the full processing log?

Thank you for your response. This a screenshot of the console

1 Like

Are you able to copy and paste the full text from the console? It would be helpful.

Also, can you please confirm what version you’re using?

So sorry, i did note save to text the log from console.
The version of odm i’m using now is 2.6

1 Like

Please upgrade to the current version and re-try your analysis with the same settings you used before:

Hello! thank you for your last suggestion.
update was done and i retried the processing, But there was the same error.
this is a copy past of the console :

2022-01-03 09:08:53,779 DEBUG: Undistorting image 010DJI0701.JPG
2022-01-03 09:08:53,871 DEBUG: Undistorting image 010DJI0457.JPG
2022-01-03 09:08:53,874 DEBUG: Undistorting image 010DJI0458.JPG
2022-01-03 09:08:53,889 DEBUG: Undistorting image 010DJI0459.JPG
2022-01-03 09:08:54,041 DEBUG: Undistorting image 030DJI0616.JPG
[INFO] running “C:\ODM\SuperBuild\install\bin\opensfm\bin\opensfm” export_visualsfm --points “D:\Processing\code\submodels\submodel_0000\opensfm”
[INFO] Finished opensfm stage
[INFO] Running openmvs stage
[INFO] running “C:\ODM\SuperBuild\install\bin\opensfm\bin\opensfm” export_openmvs “D:\Processing\code\submodels\submodel_0000\opensfm”
[INFO] Running dense reconstruction. This might take a while.
[INFO] Estimating depthmaps
[INFO] running “C:\ODM\SuperBuild\install\bin\OpenMVS\DensifyPointCloud” “D:\Processing\code\submodels\submodel_0000\opensfm\undistorted\openmvs\scene.mvs” --resolution-level 2 --min-resolution 500 --max-resolution 1712 --max-threads 12 --number-views-fuse 2 -w “D:\Processing\code\submodels\submodel_0000\opensfm\undistorted\openmvs\depthmaps” -v 0 --geometric-iters 0
12:40:53 [App ] Build date: Dec 24 2021, 00:39:57
12:40:53 [App ] CPU: Intel(R) Core™ i7-8700 CPU @ 3.20GHz (12 cores)
12:40:53 [App ] RAM: 47.82GB Physical Memory 128.00TB Virtual Memory
12:40:53 [App ] OS: Windows 8 x64
12:40:53 [App ] SSE & AVX compatible CPU & OS detected
12:40:53 [App ] Command line: D:\Processing\code\submodels\submodel_0000\opensfm\undistorted\openmvs\scene.mvs --resolution-level 2 --min-resolution 500 --max-resolution 1712 --max-threads 12 --number-views-fuse 2 -w D:\Processing\code\submodels\submodel_0000\opensfm\undistorted\openmvs\depthmaps -v 0 --geometric-iters 0
12:41:14 [App ] Preparing images for dense reconstruction completed: 2596 images (19s442ms)
12:41:41 [App ] Selecting images for dense reconstruction completed: 2596 images (26s790ms)
Estimated depth-maps 2596 (100%, 14m31s874ms)
Filtered depth-maps 2596 (100%, 9m48s721ms)

===== Dumping Info for Geeks (developers need this to fix bugs) =====
Child returned 3221226505
Traceback (most recent call last):
File “C:\ODM\stages\odm_app.py”, line 94, in execute
self.first_stage.run()
File “C:\ODM\opendm\types.py”, line 346, in run
self.next_stage.run(outputs)
File “C:\ODM\opendm\types.py”, line 346, in run
self.next_stage.run(outputs)
File “C:\ODM\opendm\types.py”, line 346, in run
self.next_stage.run(outputs)
[Previous line repeated 1 more time]
File “C:\ODM\opendm\types.py”, line 327, in run
self.process(self.args, outputs)
File “C:\ODM\stages\openmvs.py”, line 100, in process
raise e
File “C:\ODM\stages\openmvs.py”, line 91, in process
run_densify()
File “C:\ODM\stages\openmvs.py”, line 86, in run_densify
system.run(’"%s" “%s” %s’ % (context.omvs_densify_path,
File “C:\ODM\opendm\system.py”, line 106, in run
raise SubprocessException(“Child returned {}”.format(retcode), retcode)
opendm.system.SubprocessException: Child returned 3221226505

===== Done, human-readable information to follow… =====

[ERROR] The program exited with a strange error code. Please report it at https://community.opendronemap.org
[INFO] ========================
[INFO] Processing submodel_0001
[INFO] ========================
[INFO] running “C:\ODM\run” --dtm --feature-quality medium --matcher-type bow --feature-type akaze --orthophoto-cutline --dem-euclidean-map --skip-3dmodel --skip-report --project-path “D:\Processing\code\submodels” submodel_0001
[INFO] DTM is turned on, automatically turning on point cloud classification
[INFO] Initializing ODM 2.7.0 - Mon Jan 03 13:09:53 2022
[INFO] ==============
[INFO] auto_boundary: False
[INFO] boundary: {}
[INFO] build_overviews: False
[INFO] camera_lens: auto
[INFO] cameras: {}
[INFO] cog: False
[INFO] copy_to: None
[INFO] crop: 3
[INFO] debug: False
[INFO] dem_decimation: 1
[INFO] dem_euclidean_map: True
[INFO] dem_gapfill_steps: 3
[INFO] dem_resolution: 5
[INFO] depthmap_resolution: 640
[INFO] dsm: False
[INFO] dtm: True
[INFO] end_with: odm_postprocess
[INFO] fast_orthophoto: False
[INFO] feature_quality: medium
[INFO] feature_type: akaze
[INFO] force_gps: False
[INFO] gcp: None
[INFO] geo: None
[INFO] gps_accuracy: 10
[INFO] ignore_gsd: False
[INFO] matcher_neighbors: 8
[INFO] matcher_type: bow
[INFO] max_concurrency: 12
[INFO] merge: all
[INFO] mesh_octree_depth: 11
[INFO] mesh_size: 200000
[INFO] min_num_features: 8000
[INFO] name: submodel_0001
[INFO] optimize_disk_space: False
[INFO] orthophoto_compression: DEFLATE
[INFO] orthophoto_cutline: True
[INFO] orthophoto_kmz: False
[INFO] orthophoto_no_tiled: False
[INFO] orthophoto_png: False
[INFO] orthophoto_resolution: 5
[INFO] pc_classify: True
[INFO] pc_csv: False
[INFO] pc_ept: False
[INFO] pc_filter: 2.5
[INFO] pc_geometric: False
[INFO] pc_las: False
[INFO] pc_quality: medium
[INFO] pc_rectify: False
[INFO] pc_sample: 0
[INFO] pc_tile: False
[INFO] primary_band: auto
[INFO] project_path: D:\Processing\code\submodels
[INFO] radiometric_calibration: none
[INFO] rerun: None
[INFO] rerun_all: False
[INFO] rerun_from: None
[INFO] resize_to: 2048
[INFO] sfm_algorithm: incremental
[INFO] skip_3dmodel: True
[INFO] skip_band_alignment: False
[INFO] skip_orthophoto: False
[INFO] skip_report: True
[INFO] sm_cluster: None
[INFO] smrf_scalar: 1.25
[INFO] smrf_slope: 0.15
[INFO] smrf_threshold: 0.5
[INFO] smrf_window: 18.0
[INFO] split: 999999
[INFO] split_image_groups: None
[INFO] split_overlap: 150
[INFO] texturing_data_term: gmi
[INFO] texturing_keep_unseen_faces: False
[INFO] texturing_outlier_removal_type: gauss_clamping
[INFO] texturing_skip_global_seam_leveling: False
[INFO] texturing_skip_local_seam_leveling: False
[INFO] texturing_tone_mapping: none
[INFO] tiles: False
[INFO] time: False
[INFO] use_3dmesh: False
[INFO] use_exif: False
[INFO] use_fixed_camera_params: False
[INFO] use_hybrid_bundle_adjustment: False
[INFO] verbose: False
[INFO] ==============
[INFO] Running dataset stage
[INFO] Loading dataset from: D:\Processing\code\submodels\submodel_0001\images
[INFO] Loading 3761 images
[INFO] Wrote images database: D:\Processing\code\submodels\submodel_0001\images.json
[INFO] Found 3761 usable images
[INFO] Parsing SRS header: WGS84 UTM 38S
[INFO] Finished dataset stage
[INFO] Running split stage
[INFO] Normal dataset, will process all at once.
[INFO] Finished split stage
[INFO] Running merge stage
[INFO] Normal dataset, nothing to merge.
[INFO] Finished merge stage
[INFO] Running opensfm stage
[WARNING] D:\Processing\code\submodels\submodel_0001\opensfm\image_list.txt already exists, not rerunning OpenSfM setup
[WARNING] D:\Processing\code\submodels\submodel_0001\opensfm\exif already exists, not rerunning photo to metadata
[WARNING] Detect features already done: D:\Processing\code\submodels\submodel_0001\opensfm\features exists
[WARNING] Match features already done: D:\Processing\code\submodels\submodel_0001\opensfm\matches exists
[WARNING] Found a valid OpenSfM tracks file in: D:\Processing\code\submodels\submodel_0001\opensfm\tracks.csv
[WARNING] Found a valid OpenSfM reconstruction file in: D:\Processing\code\submodels\submodel_0001\opensfm\reconstruction.json
[INFO] running “C:\ODM\SuperBuild\install\bin\opensfm\bin\opensfm” export_geocoords --reconstruction --proj “+proj=utm +zone=38 +south +datum=WGS84 +units=m +no_defs +type=crs” --offset-x 512705.0 --offset-y 8032620.0 “D:\Processing\code\submodels\submodel_0001\opensfm”
[INFO] Updating D:\Processing\code\submodels\submodel_0001\opensfm\config.yaml
[INFO] undistorted_image_max_size: 1418
[INFO] Undistorting D:\Processing\code\submodels\submodel_0001\opensfm …
2022-01-03 13:23:49,556 DEBUG: Undistorting image 1080DJI0319.JPG
2022-01-03 13:23:49,556 DEBUG: Undistorting image 3040DJI0173.JPG
2022-01-03 13:23:49,557 DEBUG: Undistorting image 1090DJI0408.JPG
2022-01-03 13:23:49,558 DEBUG: Undistorting image 200DJI_0296.JPG
2022-01-03 13:23:49,558 DEBUG: Undistorting image 3030DJI0152.JPG
2022-01-03 13:23:49,558 DEBUG: Undistorting image 2050DJI0018.JPG
2022-01-03 13:23:49,558 DEBUG: Undistorting image 3040DJI0339.JPG
2022-01-03 13:23:49,559 DEBUG: Undistorting image 2080DJI0073.JPG
2022-01-03 13:23:49,559 DEBUG: Undistorting image 2060DJI0934.JPG
2022-01-03 13:23:49,559 DEBUG: Undistorting image 3030DJI0400.JPG
2022-01-03 13:23:49,559 DEBUG: Undistorting image 2070DJI0456.JP

1 Like

Are you able to share your dataset somewhere?

Also, is your Windows 8 machine fully up to date?

unfortunatly i can not share the dataset yet!
yes, I think the OS is up to date

So, might it be an issue from the OS?

1 Like

Really hard to say without being able to see/use the data.

Can you use a different feature type? SIFT instead of AKAZE and re-test?

for precision the OS is an Windows 10 Pro
For the feature type option, i have already used Shift as feature type before, with the 2.6.7 version of the ODM, no sucess.

If i use docker ODM instead of Windows, will it change something?

1 Like

It’s quite possible you might be running out of memory?

2596 images with 48GB of RAM is often not sufficient.

Have you tried with fewer images?

1 Like

ohhh! I use 350 images with split 100 and split overlap 50 and it woks until new error went up
and this script is open automaticaly:
#!/usr/bin/env python3

import sys
#import osgeo.utils.gdal_proximity as a convenience to use as a script
from osgeo.utils.gdal_proximity import * # noqa
from osgeo.utils.gdal_proximity import main
from osgeo.gdal import deprecation_warn

deprecation_warn(‘gdal_proximity’, ‘utils’)
sys.exit(main(sys.argv))

Durring DEM merging i think
I cheked all dtm files in submodels folders and and i think all is ok
The strang one is that i did not put any --dsm flag, so why i have such error from dsm processing stage
this is the log:

[WARNING] Found a split done file in: D:\Processin\code\opensfm\split_done.txt
[INFO] Finished split stage
[INFO] Running merge stage
[WARNING] Found merged point cloud in D:\Processin\code\odm_georeferencing\odm_georeferenced_model.laz
[WARNING] Found merged orthophoto in D:\Processin\code\odm_orthophoto\odm_orthophoto.tif
[INFO] Merging DTMs
[INFO] Computing euclidean distance: D:\Processin\code\submodels\submodel_0000\odm_dem\dsm.euclideand.tif
[INFO] running gdal_proximity.py “D:\Processin\code\submodels\submodel_0000\odm_dem\dtm.tif” “D:\Processin\code\submodels\submodel_0000\odm_dem\dsm.euclideand.tif” -values -9999.0
[WARNING] Cannot compute euclidean distance file: D:\Processin\code\submodels\submodel_0000\odm_dem\dsm.euclideand.tif
[INFO] Computing euclidean distance: D:\Processin\code\submodels\submodel_0001\odm_dem\dsm.euclideand.tif
[INFO] running gdal_proximity.py “D:\Processin\code\submodels\submodel_0001\odm_dem\dtm.tif” “D:\Processin\code\submodels\submodel_0001\odm_dem\dsm.euclideand.tif” -values -9999.0
[WARNING] Cannot compute euclidean distance file: D:\Processin\code\submodels\submodel_0001\odm_dem\dsm.euclideand.tif
[INFO] Computing euclidean distance: D:\Processin\code\submodels\submodel_0002\odm_dem\dsm.euclideand.tif
[INFO] running gdal_proximity.py “D:\Processin\code\submodels\submodel_0002\odm_dem\dtm.tif” “D:\Processin\code\submodels\submodel_0002\odm_dem\dsm.euclideand.tif” -values -9999.0
[WARNING] Cannot compute euclidean distance file: D:\Processin\code\submodels\submodel_0002\odm_dem\dsm.euclideand.tif
[INFO] Computing euclidean distance: D:\Processin\code\submodels\submodel_0003\odm_dem\dsm.euclideand.tif
[INFO] running gdal_proximity.py “D:\Processin\code\submodels\submodel_0003\odm_dem\dtm.tif” “D:\Processin\code\submodels\submodel_0003\odm_dem\dsm.euclideand.tif” -values -9999.0
[WARNING] Cannot compute euclidean distance file: D:\Processin\code\submodels\submodel_0003\odm_dem\dsm.euclideand.tif
[INFO] 0 valid DEM rasters to merge
Traceback (most recent call last):
File “C:\ODM\run.py”, line 60, in
retcode = app.execute()
File “C:\ODM\stages\odm_app.py”, line 130, in execute
raise e
File “C:\ODM\stages\odm_app.py”, line 94, in execute
self.first_stage.run()
File “C:\ODM\opendm\types.py”, line 346, in run
self.next_stage.run(outputs)
File “C:\ODM\opendm\types.py”, line 346, in run
self.next_stage.run(outputs)
File “C:\ODM\opendm\types.py”, line 327, in run
self.process(self.args, outputs)
File “C:\ODM\stages\splitmerge.py”, line 295, in process
merge_dems(“dtm.tif”, “DTM”)
File “C:\ODM\stages\splitmerge.py”, line 272, in merge_dems
euclidean_merge_dems(all_dems, dem_file, dem_vars, euclidean_map_source=eu_map_source)
File “C:\ODM\opendm\dem\merge.py”, line 66, in euclidean_merge_dems
dst_w, dst_s, dst_e, dst_n = min(xs), min(ys), max(xs), max(ys)
ValueError: min() arg is an empty sequence

1 Like

It looks like you may need to reprocess from earlier if it has failed to generate valid intermediate products.

Do you have a large SSD you can make a big pagefile on?

I used rerun all, no sucess, same error
I use HDD drive for dataset path. SSD containe only the OS, its not big enought.

for information , I try the 350 images without the split-merge option and it works perfectly.

So i think, there is something wrong with the split merge

Or my final purpose is about processing up to 11000 images. So i must use split-merge option.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.