Error 137 (out of memory) in windows or WSL even with 50GB RAM


I just got a new machine (i9, 64GB RAM) and tried to run a dataset in WebODM. The same dataset was processed correctly in a Mac with 32GB RAM.

I tried using Docker for Windows and also installing Ubuntu in WSL-2 and then installing WebODM inside Ubuntu. In WSL, I can see that I have 50GB of RAM.

I tried with and without splitting, same error. Also tried max-concurrency=1, same error.

here are the last lines of the output:

2021-02-09 16:13:52,947 DEBUG: Computing sift with threshold 0.1
Traceback (most recent call last):
File “/code/”, line 69, in
File “/code/stages/”, line 83, in execute
File “/code/opendm/”, line 360, in run
File “/code/opendm/”, line 341, in run
self.process(self.args, outputs)
File “/code/stages/”, line 59, in process
File “/code/opendm/”, line 279, in feature_matching‘detect_features’)
File “/code/opendm/”, line 27, in run‘%s/bin/opensfm %s “%s”’ %
File “/code/opendm/”, line 79, in run
raise Exception(“Child returned {}”.format(retcode))
Exception: Child returned 137

So: is error 137 only for out-of-memory? If not, what else? Is it possible that I’m missing any dependency?



Hmm, can you update your docker image again, and maybe do another git pull for your WSL2 image?

1 Like

Aannnnd… it works!



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.