Eleveation Map Error

Im having an ERROR when i open Elevatin Map

Hey @Dilmar_Ferreira_Jr!

What error are you getting?

Can you share a screenshot?

1 Like

Hi, if a hit preview or export i get this msg.
39

Yep, that definatelly looks like an error, might be a bug.

Could I ask you 2 things?

First, is your dataset shareable? I would like to try to reproduce the problem so I can see what’s going on. If you can share it, on the Dashboard, select the task and download the “all.zip” file by selecting “All Assets”. You can share it by using Google Drive or Dropbox for example.
Screenshot%20from%202019-07-30%2009-40-19

Second, what version of ODM are you using? How are you running it? You can check the version on the Diagnostic section on the left.
Screenshot%20from%202019-07-30%2009-40-35

1 Like

Hi, here a there files.

And the version is 1.1.2
23

Hey @Dilmar_Ferreira_Jr!

So this is weird.

I downloaded the latest WebODM version, imported your zip as a task, enabled the Elevation Map plugin, run it with the same parameters, and it worked.
Screenshot%20from%202019-07-30%2013-26-40

Could you try to do the same? Re-import your zip into a task (to do so, on the project, instead of choosing “Select Images and GCP”, select “Import”) and run the plugin again on the new task?

Also, how are you running ODM? Are you using Docker, running it natively?

Ok. i will import.
I dont know how to use Docker. I buy the script, intalled a ubuntun 16.4 and them i run the script… thats all i know.

The error persists after importing… 18

Hi, is there somenthing i can do?

Maybe a silly question here, but did you restart webodm before uploading the zip?
I would recommend to run:

./webodm.sh update
./webodm.sh restart

And then try again. Maybe you have some package that did not install properly?

i´m getting a file not found.
40

And the file is there… look43

I think i´m doing somenthing wrong…47

I’m not sure how the installer actually works. If it uses Docker or not.

@pierotofy can maybe bring some light into the issue :slight_smile:

This is a native install, so the ./webodm.sh script will not work.

It’s likely that the plugin failed to install the dependencies.

Try to disable the plugin, then re-enable it and restart the virtual machine for good measure.

Nop! Still error msg! :pensive:

What else can i do?

Maybe you can install the dependencies on your own. They are listed here

You can install the dependencies with pip by doing pip install -r requirements.txt. Hopefully, that will work.

No success! 06

Somenthig else i could do?