Duplicate with offset in processed Dataset

Hey guys,

i have a giant offset in one dataset (Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.) after processing. Do you have any Idea what the reason could be?
the options: auto-boundary: true, dsm: true, dtm: true, feature-quality: ultra, mesh-octree-depth: 12, mesh-size: 9999999, min-num-features: 40000, orthophoto-resolution: 1, pc-geometric: true, pc-quality: ultra, pc-rectify: true, split: 200, split-overlap: 150

was run on a cluster with 2 nodes.



Is your flight path is same as this one?

1 Like

Nearly. Have a look at the planned path, there was one additional flight from top center to bottom center.


Its strange, from this cameras GeoJSON, It is already know that DJI_753.jpg, DJI_754.jpg, …, DJI_769.jpg have two different location. Seems error in camera position reconstruction.

1 Like

I checked the files, but there are no duplicated images.

1 Like

I think we saw similar offset/distortion with Gordon’s work over a really large area due to Rolling Shutter Distortion…

Oh, how I wish I could squash that from our pipeline :expressionless:

1 Like

Ok, that could be. Drone flew with much speed.

1 Like

I will create the same dataset again the next days with a stop for every picture. Will be time consuming for sure


Can you give details about how you got Litchi to map fly for ODM mapping?

un-related to the issue sorry just I saw a post on Litchi lately where people were not sure how to get the camera to take photos correctly as using a mission plan with curved corners prevents running commands on waypoints like take a photo or start/stop recording etc.


I will create the same dataset again the next days with a stop for every picture. Will be time-consuming for sure

Litchi users I have noticed had that issue as well, stopping for every photo you will have too turn off curved corners for waypoints as this prevents execution of tasks you define on your waypoints.


I create flight plans in DJIFlightPlanner and import into Litchi.

I’ve had no issue with adjusting settings at waypoints, curve size is always set to zero in my experience. The only time I have seen it not set to zero is when I have moved the waypoints around in position and altitude in Litchi, but I don’t think it prevented any extra commands being edited in.

Yes, there have been instances of that, but I have also successfully stitched large areas of over 3300 images, and had most of an area of over 7000 images stitch ok too.

1 Like

Specific it is when the drone mission for waypoint has enabled curved corners ‘enabled’ setting this will create a dialogue pop up when editing waypoint tasks saying that the task will not run with curved waypoint enabled… I was just informing for getting a start and stop for each pic you will need to disable curved waypoint mode if enabled otherwise issuing drone wait and take the photo then go to the next waypoint etc will fail to function as expected.


OK, that must be when flight plans are created within Litchi, as the DJI FP export does not have any option for curved corners, and it doesn’t appear as an option after importing from DJI FP.

Path Mode → Curved

An identical setting can be enabled in the Mission Settings in the Litchi App.
I say this because of your Litchi Mission Overview image I see this…
Screenshot 2022-02-19 173114
That cyan curve on the way point is a curved path.

Straight Path

Curved Path

In the actual Litchi App for Mission Settings, the app will warn you that waypoint actions are not possible while flying with a curved path, but it will not stop you adding actions.


I can produce curved turns at waypoints, but curve size zero is the default I see.

However, I notice that I have “75%” take photos on this plan I set up this week, with the drone stopping for each image, for producing a 3D model.

1 Like

To reduce the rolling shutter you should ad action wait 0.1 before the photo option. Also to apply this on all points, select a second point with the ctrl key on your keyboard, then select ‚apply all‘ in the litchi waypoint settings


Curved Size = 0m will not fix the issue IRC the actual Mission Settings for that flight must be set to Straight Turns with 0m curve size it will still make smaller than 1m size curves :wink:

I updated my post as you replied before I finished adding details to the prev post of mine.
I don’t exactly know what
Screenshot 2022-02-19 173114
Is doing as I don’t set actions with % values like that.

The way I would have flown it is like this -
Screenshot 2022-02-19 173114

Sit still for .5 of a second to stabilize drone before camera photo then take photo before it moved onto the next waypoint.

Also I can see some kind of error appearing from perhaps import of the DjiFlightPlanner
Action ‘Take Photo’ has no input available as you can see on the Litchi Mission Hub that box is greyed out meaning it has no configurable value.

Also in your litchi mission planner as I stated previously I can see CYAN coloured curved paths just like example in this reply.

This tells me you do indeed have curved turns, so take photo action should not even be working according to what Litchi tells me when I enable that option in the actual phone app.

Are you preparing your flight plans with Litchi? It isn’t an issue when preparing flight plans with DJI FP, the turns are straight unless you set them to be curved. If the photos are being taken every 2 seconds, then they will continue through any curved turns you have set.

Me either, the 75% just appears sometime afterwards.
When the camera is exported from DJI FP with ‘stop to take photos’ I do not need to adjust each way point with a stay for time, as it takes the photo after stopping automatically.

‘Take photo’ is the value, performed when it stops at the way point, it doesn’t need any more configuration.

That’s in Maurice’s FP, not mine

1 Like

Yeah, I use Litchi or DroneLink Mission Planners I find them more robust, unsure if the DJI FlightPlanner works for non-enterprise drones when actually using the app they use, which used to be DJI Pilot that only works on the Mavic 2 Pro I tried that on my Mini 2 and no success there, but that I did format my Smart Controller during cleanup when I sold one my other drones because I had not used the controller in a while so started fresh.

I forgot last time I found a modified DJI Pilot app which was changed to allow more DJI drones to work as I don’t believe apps should be locked to “enterprise-only” drones the drones all have most of the same sensors at the Pilot app the official DJI waypoint software has no reason to not work on the consumer models :sweat_smile:

I see, I don’t need to add the wait action I choose too, this gives guarantees the drone can have a small window to stop and stabilize motion before taking a photo. The effectiveness I have not measured I add it so the drone can stop and then sit there half a second to become a bit more stable from the halt of stopping before taking a pick, does it do that on its own I honestly never tested outright letting it just take a photo I thought the drone would stop then instantly take a photo I wanted to allow a little more wait time in-case of a gust or something so it had the chance to become a bit more steady from coming to a stop.

oh… right… my mistake.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.