DTM Not Correctly Created

Hi everyone!

I’m having trouble in creating DTM in ODM. The produced DTM only have two wrong values. Here are the parameters I’m using:

--dtm --dsm --orthophoto-resolution 4 --orthophoto-png --dem-resolution 4 --ignore-gsd

I noticed an interesting output before the process finished:

ERROR 1: /home/sysadm/Documents/rasters/Sawit Condong 1/odm_dem/dtm.preview.tif, band 1: Failed to compute statistics, no valid pixels found in sampling.

My PC is on Kubuntu 20.04. I’ve uploaded some sample raw images, DTM tif output & complete process logs in this link https://drive.google.com/drive/folders/1mLGq1OVlypRStY6iBBkX94a-beFslzRy?usp=sharing.

What can be the problem of this?

Thank you.


It’s best not to use ignore-gsd, it does cause a lot of problems with many datasets. It really is time for developers to make it really hard to select! :wink:
Are there only 5 images in total?
Based on those 5 images, it is quite difficult set of images to work with, especially if there was any wind, as the trees cover such a large part of the scene. Increasing minimum number of features significantly may help.




No, there are 300+ images in total. Will continue uploading the rest of images when the connection is better.

Unfortunately, I’ve also tried only using --dtm and --dsm parameter and the DTM still not produced correctly. But with other previous datasets, it was all fine. I really can’t caught what makes two of them different.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.