DroneDB Registry Self-Host Help

Has anybody configured a publically visible instance on Registry on a windows machine ?

I have configured a DDNS to point to my home router and can port-forward successfully to a WebODM Docker instance but I’m having no luck connecting to a Registry Docker instance.

I can connect to a Registry Docker instance across my local network but I need to be able to access my database remotely, without using a VPN.

1 Like


Have you checked the Running In Production section to ensure the proper port is opened for Registry?:

I have opened port 5000 TCP for all inbound and outbound connections in Windows Firewall with no change.

I have also (briefly) tried turning off the firewall entirely and that makes no difference.

1 Like

Then you might need to be looking at your Modem/Router.

In my router I am forwarding port 5000 to the local IP of the machine hosting the Docker instance. Exactly the same way I am forwarding port 8000 to the local IP of the machine hosting WebODM.

1 Like

Looks like I have bigger problems right now; on a fresh install using default user:pass, I can create a new dataset, upload imagery and preview on the map screen. When I then disconnect/reconnect using the same machine (or different machine) I get ’ TypeError: Failed to Fetch ’

I wasn’t sure if this was a cookies or cache related thing but I get the same result using Edge browser.

From within Docker I’ve tried deleting the container / image / volume to start from scratch but I keep getting the same result…

1 Like

Looks like the TypeError is related to setting the external URL in .env

If I comment out the external URL line in .env I can at least get to my database. Back to figuring out how to make Registry respond to a public IP

1 Like

In a nutshell, it appears it can’t be done in Docker Desktop (Windows machine)

I currently have an instance of DroneDB running on a Linux VM within Windows 10 that can be reached from the internet. In this particular setup I have multiple network cards installed so have been able to assign a dedicated network card to the VM which greatly simplifies the network configuration.

Now to figure out how to access user management for creating a dataset that isn’t linked to the admin user.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.