Don't have Share Button on 'View Map' feature in windows native

This is native Windows WebODM ‘View Map’ option for a particular task. And same for project also. I’m not getting any ‘share’ button here.

How can I get this feature in my WebODM windows native app.
Also, I’m not able to create an instance of it on’localhost:8000’ or ‘localhost:8000/login/’ .
How should I proceed?

1 Like

Change C:\WebODM\resources\app\apps\WebODM\webodm\local_settings.py:

DESKTOP_MODE = False

You can then also edit C:\WebODM\resources\app\main.js at line ~152 and replace the address of the waitress process to bind on an interface different than 127.0.0.1.

Note: it sounds like you’re trying to run WebODM as a server. I’d recommend using a Linux machine and running WebODM with docker instead.

The desktop app might not be the best tool/choice for your job here.

2 Likes

Thanks sir !
That worked! (‘Share’ option part)
I’ll take care of your advice.

  1. How can I access this generated URL outside my local network ?

  2. How can I automate the whole process in the ‘Windows 10 Desktop native’ version , from running a Task to generating a URL (Public) for that…
    Task:

  3. Running the 'Create Task in Project ’ through a command line or python script.

  4. Generating the ‘Public’ URL from ‘Command Line’ / ‘Python Script’ only?

Also, I tried to change waitress process IP to my server’s IP.
The WebODM doesn’t start then.
Do I’ve to change anything else ?

  1. You will need to manage your network topology to enable such access. This will be a combination of firewall rules, NAT, port forwarding, and possibly DNS registration to make the URL easier to use.

  2. What do you mean by automating? You could probably write a wrapper script in python to control ODM.

  3. I think the REST API is best suited for this.

  4. The Share option is meant for internal/intranet access. You can expose your computer to the wider internet, though.

This part is not working. It just stops WebODM from launching. Giving an error message to check firewall setting to allow webODM through it.
I did but that didn’t worked. So please tell me, what did I do wrong?

ohk got it!
can you please tell me how can I change rhe default port of WebODM instance.
link - localhost:28900
i want to change it to
localhost:4002
@ Piero Toffanin is a moderator

Piero Toffanin

Can you adjust it in the main.js where Piero directed you to adjust the localhost address?

I tried. But then WebODM doesn’t start or launch. It shows some error regarding make sure WebODM is allowed through firewall. I made the changes but it is not starting.

I almost done in my project. Just a security thing left.
when I generate a URL, it redirects you to the ‘View Map’ feature of that particular task.


But in this screenshot, top left corner, when you click at webODM logo, it redirects you to dashboard.
How can I remove that link from there or restrict viewers to see just ‘View’ Part.
I tried the adding user thing , but that doesn’t work in the URL part. They’re always public.

Probably need to modify the source code of the page to remove that link.

Where would you have it redirect to?

No where. Just want to stop it to going to DASHBOARD or something else in that view part.
You tell me the line of particular code, I’ll do the changes.
@pierotofy
Sir , see if you can help.

I don’t know the codebase well enough to point you to the line in the code.

Have you looked at the main.js?

Have you tried the browser’s inspection/source code view tools to see if you can “pick” that element and find what constructs it in the code?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.