Does this look correct?

I’ve recently tried WebODM for windows for the first time, but it is excruciatingly slow.

Its taken over 17 hours to process 671 images. My computer is decently powerful and I would have thought it would take a couple of hours at most.

I’m running the processing on the highest settings.

Does WebODM only use the CPU or can it use a dedicated GPU as well?

Any advice would be appreciated.

1 Like

There’s only CPU at the moment, it’s seems that ODM can use the GPU.

I also use Ultra settings and with swift it takes about 3h to process 100 images.

1 Like

Try feature-type: orb, it is massively faster.

What outputs were you trying to produce?


Ah alright. So this seems about right then.

It is not feasible for large projects then. 30000 images would take weeks if not months.


All default outputs, DSM, Ortho, Model, pointlcoud.

I would type that into the commands before starting?

In WebODM just select it from the drop down EDIT list.

I’m nearly 31 hours into a 7842 image set, and suspect I’m well over half way through - a bit hard to tell as the progress bar movement is non-linear.

Ah alright :person_facepalming:.

Oh wow. Well good luck. My project just finished and it took 19 hours for 671 images with an AMD 5900hs 32gb RAM + NVME page file and an RTX3080.

I’m a newb at WebODM right now but it sounds like your 7000+ images will take more than 40 hours+?

What do you think about the quality of roofs in your models/pointclouds/DSMs? I’m not too happy especially when comparing it to the likes of Metashape.

But then again Metashape is not cheap.

I’m happy with the result. Settings is important!

Generally pretty good roof shapes, with enough image overlap and correct settings.

With intel i7 3.8GHz 96GB RAM, 4963 images over 5km^2 area took 15 hours to process, although I did resize… but that was before I discovered ORB!

1 Like

What settings would you recommend for better roofs?

I will try orb later today.

1 Like

I set things high, no cropping of images, ultra quality. You can try not to use 3D model for ortophoto, it might help. And set the ortophoto resolution to something else.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.