Docker? Start WebODM?

Hi,
I’ve just installed everything needed (i think) on a Ubuntu desktop.
following the guide and came down to this step:

Step 3. Download and Launch WebODM

From a terminal type:

$ cd WebODM
$ ./webodm.sh start

Then open a web browser to http : //localhost:8000.

But when using the ./webodm.sh start command the Terminal gives the following output:

:~/WebODM$ ./webodm.sh start
Checking for docker… OK
Checking for git… OK
Checking for docker-compose… OK
Starting WebODM…

Using the following environment:

Host: localhost
Port: 8000
Media directory: appmedia
SSL: NO
SSL key:
SSL certificate:
SSL insecure port redirect: 80
Celery Broker: redis://broker
Default Nodes: 1

Make sure to issue a ./webodm.sh down if you decide to change the environment.

docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml start || docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml up --scale node-odm=1
ERROR: Couldn’t connect to Docker daemon at http +docker://localhost - is it running?

If it’s at a non-standard location, specify the URL with the DOCKER_HOST environment variable.
ERROR: Couldn’t connect to Docker daemon at http+docker://localhost - is it running?

If it’s at a non-standard location, specify the URL with the DOCKER_HOST environment variable.

And of course when trying to open //localhost:8000/ I just get an notice that Firefox cant find the adress…

What am i doing wrong??

Best regards Andreas

Make sure your current user (“andreas” or whatever) is also a member of the “docker” group. Make sure you append the group (usermod -G not -g). You may need to reboot.

1 Like

Or login and log back out, or just run
su - ${USER}
to login again with the current group permissions.

Thank you! This worked!

I did the following:

  1. Create the docker group.
$ sudo groupadd docker
  1. Add your user to the docker group.
$ sudo usermod -aG docker $USER
  1. Log out and log back in so that your group membership is re-evaluated.If testing on a virtual machine, it may be necessary to restart the virtual machine for changes to take effect.On a desktop Linux environment such as X Windows, log out of your session completely and then log back in.On Linux, you can also run the following command to activate the changes to groups:
$ newgrp docker 
  1. Verify that you can run docker commands without sudo .
$ docker run hello-world
2 Likes

Hi,

I am completely new to docker, but had finally gotten a working WebODM (with docker) running on my Windows machine. I was testing the software with my multispec data when it started complaining that I might had run out of disc space (I had run it before on RGB data). I tried to cancel the run in the browser interface, but with no success. I ended up just closing all the open windows (browser, bash prompt after I used Ctr-C to quite, docker and virtual box). After reopening everything I got the same error as described in this post. Does anyone perhaps know, what could have changed and why, and how can I address this in Windows?

How do I…

… as Corey suggested?

I did try the sudo/su route in the GitBash shell where I was running WebODM from, but seems like I would have to install sudo. I would prefer avoiding the sudo/su route, is there perhaps another workaround, since my WebODM/docker used to work?

1 Like

Hey!

Do you have the data somewhere else? You could reset your docker images and start over clean.

Reinstalling docker and WebODM got my WebODM opening up again. Will test it now. Thanks Saijin_Naib

2 Likes

Glad you’re up and running, but sorry you had trouble.

If something new pops up, please feel free to make a new thread so we can keep track.

Including things like system specs, dataset link, and processing parameters are always welcome and super helpful.

Thanks! Just ran into my next bump. Made a post, hope I added enough detail. I have to say this is really a very supporting community, thanks again.

2 Likes

Sorry you hit another snag.

Your post looks great so far!

Thanks. We all try to be as helpful as possible here :slight_smile: