DJI P4MS stripey multispectral images

Continuing the discussion from DJI P4MS Errors:

Was there any solution to handle this stripey images?
I have the same problem with DJI Phantom4 Multispectral images
image
And what is strange the stripes changes if I process just part of the images:
This is the upper corner of the plot (used the last18 images only):
image
I have tried with different radiometric calibration parameters, but the it does not affect the result.
I have checked the images and both the sun sensor value is quite different in images from the different stripes (opposite flying direction), so it seems it is not calculated correctly image by image.
It would be worth to fix, because otherwise the process works rather well on P4MS images.

1 Like

Hello,

I haven’t received a resolution to my issue. I downloaded test versions of Pix4D Fields and Agisoft Metashape and as far as I can tell from what I processed, these errors don’t appear in either software platform; I was able to calculate band maths and known Vegetation Indices in Pix4D with no problem. I have an associate that can’t process my images on his software either which (as I understand it) is similar to this ODM process.

Work to better support various multispectral sensors is still underway :slight_smile:

If you have an issue processing a dataset: please share the input images + the parameters you used for processing.

1 Like

Understood, thank you!

2 Likes

It is a quite big dataset, I think to investigate the problem it is enough to share just a smaller part of it. I will prepare the images and save the settings too and post the link here.

1 Like

Here you can find the dataset:
https://drive.google.com/drive/folders/1vHY0e6st3Tjnwc-EayTpvF8rYvOBLyNZ?usp=sharing
I have added both the RGB images (.jpg) and the 5 separated bands (.tif) too, but I processed them separately. The RGB images are processed correctly, the stripes can be seen on the multispectral dataset only. The setting is the default Multispectral (texturing-skip-global-seam-leveling: true, radiometric-calibration: camera)
Uploaded the resulted orthophoto too. I could open it in QGIS and raster calculator (NDVI equation) also worked properly.

2 Likes