Could not find ccd_width in file. Use --force-ccd or

I have installed Docker for Mac v18.03.0.
Then in Terminal I typed :
git clone
then cd OpenDroneMap
docker run -it --rm -v $(pwd)/images:/code/images -v $(pwd)/odm_orthophoto:/code/odm_orthophoto -v $(pwd)/odm_texturing:/code/odm_texturing opendronemap/opendronemap
Unable to find image ‘opendronemap/opendronemap:latest’ locally
latest: Pulling from opendronemap/opendronemap
281a73dee007: Pull complete
2aea1b77cff7: Pull complete
59a714b7d8bf: Pull complete
0218064da0a9: Pull complete
ebac621dcea3: Pull complete
a3ed95caeb02: Pull complete
b580731643cc: Pull complete
faa5fbdba239: Pull complete
a3480ec159f7: Pull complete
Digest: sha256:76d12a83f5991f08980aac6bf6bc6dc535308a6fd37a2aa066d71269c725c579
Status: Downloaded newer image for opendronemap/opendronemap:latest
[INFO] Initializing OpenDroneMap app - Wed Apr 04 10:18:07 2018
[INFO] Running ODM Load Dataset Cell
[DEBUG] Loading dataset from: /code/images
[DEBUG] /code/images
[ERROR] Not enough supported images in /code/images
[INFO] OpenDroneMap app finished - Wed Apr 04 10:18:07 2018

Then I put 420 jpg files into the images folder and run the same code once more
docker run -it --rm -v $(pwd)/images:/code/images -v $(pwd)/odm_orthophoto:/code/odm_orthophoto -v $(pwd)/odm_texturing:/code/odm_texturing opendronemap/opendronemap
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG] Loaded DJI_0249.JPG | camera: dji fc6310 | dimensions: 4864 x 3648 | focal: 8.8 | ccd: None | lat: -22.7970856944 | lon: 17.1284855556 | alt: 1903.383
[INFO] Found 420 usable images
[DEBUG] Line: WGS84 UTM 33S
[INFO] Running ODM Load Dataset Cell - Finished
[INFO] OpenDroneMap app finished - Wed Apr 04 15:50:23 2018

Then I added the flag force-ccd
docker run -it --rm --force_ccd -v $(pwd)/images:/code/images -v $(pwd)/odm_orthophoto:/code/odm_orthophoto -v $(pwd)/odm_texturing:/code/odm_texturing opendronemap/opendronemap
unknown flag: --force_ccd

Am I doing something wrong?
What is the size of the P4P sensor? Where do I put that value?

It’s not really an error to not have ccd_width, just a warning. Did it finish running, or did you run into an error later?

I have the same issue. I also have a P4P. Its sensor size is 13.2 by 8.8 mm. The P4P camera is not included in the OpenSfM sensor_data.json list. The sensor_data.json file doesn’t reside on my computer after I am done generating my Docker image. Is there any way to include the sensor size as a flag when I run ODM in Docker? I believe the sensor size enters into the calibration of my ortho_texture and ortho_photo. Currently all of my measurements are too short.

Thanks for help.

I figured it out how to use the force-ccd flag. I added “–force-ccd 13.2” after my_odm_image and it ran without error.

However, it didn’t make a difference in the length calibration. I am getting the same measurements as I did without specifying the sensor size. I wonder what else could make all of my measurements about 6% shorter?