Correct workflow with Mavic M3M


I was a Pix4DFields user and now I am moving to WebODM. I have a Mavic M3M (Multispectral) and I don’t have a success using generation of my index multispectral. I make a first test using WebODM by choosing the option “Multispectral” and I also use WebODM using option “radiometric-calibration”: camera. In both cases when I look the result in my WebODM, the “Plant Health” looks not give the same result as when I use Pix4dFields.

In Pix4DFields, I just select my Orthophoto and I can generate any index supported by my camera/dataset like NDVI, GNDVI, etc. When I am in WebODM, seriously I think WebODM don’t know about use my multispectral band to display NDVI. The NDVI look like generated by the Ortophoto, similar as normal RGB.

To make my comment simple, for users who use M3M, what’s the workflow you use to generate high index multispectral and not a look fake Plant Health from RGB ?

If I am not clear, let me know.

Note : Here is result generated as multispectral from WebODM Lightning with radiometric-calibration: camera

1 Like

Have you tried taking the image into QGis?

It has a lot of functionality that might help.

You mean use function “Download: All Assets” from WebODM Lightning and open in QGis ?

1 Like

Yes, download the output and open in QGis, qgis has a lot of functionality surrounding ndvi and alike.

It needs a couple of button clicks though.

I have only done it with satellite images but I think the process should be similar

1 Like

Thanks for your suggestion but initially I look to use WebODM (UI) to play with my map and able to share it without having to use QGis.


Did you try to upload (only) the TIFF files and select “default” option.

One of our examples from a M3M.


Do you mean the file “odm_orthophoto.tif” ?


When you make a mapping with the M3M you get results in the form of RGB (JPEGs) and MS (TIFFS). Try to upload only the Tiffs when generating an NDVI map.

Yes, I am correct and I created a custom folder to put only my .tif files and upload it on my WebODM Lightning to start processing. For options, I selected only 3 options :

  • radiometric-calibration = camera+sun
  • pc-quality = high
  • texturing-skip-global-seam-leveling = enable

Do you see if I forget something ?

Mmm, do you see a possibility to share (a part) of the source tiff files? The multispectral tiffs are grouped, 4 bands for one location.

I’m interested in this topic; I too have the Mavic3M and am trying to get WebODM to work (I also have Pix4DFields). I am properly struggling with WebODM, I can’t get the local node to accept images let alone process. When I previously tried TIFFs from my La Quinta multispectral camera, WEbODM didn’t work for that either.

Here is the dataset I used

Hope you can help

Thanks, I will download the set and have a look. Will keep you posted.


BTW I really want to be able to work with WebODM instead to use Pix4DFields. I like the possibilities to share my map with someone and I always like to host my own projects. I hope I can get accurate indexes using my M3M.

Good luck. I have had literally zero success with this program. 3.6 Ghz i9 processor, 4gb graphics, 96gb RAM.
Constantly refused to process images that I know work in Pix4dFields, no explanation as to why. I’ve never been so frustrated with software; and I’m a Software Product Manager!

We come probably close of the same place in terms of Sofware engineer but I think WebODM can be better if we provide our feedback. Which persons on the forum can listen to us ? I can provide many datasets with different configurations to help.

Hi LowAltitude. Sorry for the frustration, though Orca is right: follow through on details helps us as a community help you, especially with multispectral datasets, for which each UAV/camera vendor packages things differently.

Were you able to use Tim’s scripts in this post to correct for DJI’s bug?

I never saw a follow up, so I think most of us assumed things were working for you.


Just a quick reply via my phone. I uploaded your set and processed the images with the following settings

Default, no image resizing.

It gave some promising results, see the attachments.

When I’m back home I can check the results on my laptop.


1 Like

Thanks for the reminder; I gave up on that dataset and am now trying with a new dataset from a different drone, and still no closer to anything working. I’ve deleted, re-installed, tried a 3d jpeg model, tried a 2d ortho from jpegs and it just doesn’t process.
Going to try up-ing the resources through Docker once the latest issue I’ve encountered is resolved (posted in another chat).

1 Like

Thanks for the update. If I understand, you use directly WebODM without using node WebODM Lightning right ?