Control point editor problem

I have noticed a problem with the CP editor in WebODM. Only the first CP pair gets recorded to the exported GCP file, even though the correct number of points are displayed on top of the images in the image list to the left in the editor.

I have tried to inverse the order of placement in map vs image, but no matter what only the first set per image gets into the export. This happens in both Chrome and Firefox.

Best regards

Hi Steen, are you clicking on the points on both sides to lock them to each other?

They should all be green before export.

Yes, sometimes they get green, but right now I have an image in which the first point wont turn green, even after clicking lock. I managed to get it right in another image, but mostly they wont record.

If someone could make a video tutorial on this, it would be awesome. But anyway, I can’t see what I am doing wrong… And thanks for getting back so quickly :slight_smile:

I just tried to CTRL click the points, and that turned them green and recorded into the gcp file… We definately need a tutorial on this…

Yes, a tutorial has been on the list for a while. We welcome contributions! :slight_smile: I’m glad you figured it out.

Me too, but it took a while. When I’m fisnished with thsi job I would be glad to make a tutorial.

One other thing, the base reference map imagery seems rather old and blurry, how come?

Just ran a 5 acre ortho and used GCP’s form the editor according to best practise and the tutorial and the editor. I made sure to only use GCP’s I am sure about hasn’t been changed.

What I notice is that my map is about 1.5 meters of to the south consequently. I couldn’t understand this, so I took the generrated UTM coordinates and checked them, and guess what, they are all of to the souht with same distance.

Project is in UTM zone 33 on northern hemisphere.

Maybe it woould be an idea to have a correction function in cm / inches, for local tuning.

This problem makes it impossible to use the GCP editor, unless I went in and corrected all entries in the GCP file manually.

Very interesting. Can you make an issue documenting this here?: