ClusterODM nodes

How do I see if my nodes are connected to clusterODM?
If I use
winpty node index.js --help I get
winpty: error: cannot start ‘node’: Not found in PATH

If I use http://localhost:10000 I get

This site can’t be reached

localhost refused to connect.
I am using webODM with docker.
Is there anyway to know if my other 2 computers are connected to my clusterodm?
Please bear in mind I am not very code savy.

2 Likes

Did you install NodeJS? Node.js

1 Like

Yep got that bit, I can open localhost 10000 now.
Now I get to telnet, connects but just comes up with invalid to anything I try to type in there.
I guess I am up to trying to add nodes if I can get past the invalid part?
tn1

Type

help

And it will tel you all the available commands.

Wont let me, soon as i type h it goes invalid?

Ok Have that sorted, used putty instead. now it says offline yet it is running. I have another computer hooked up, no worries, just cant find my laptop, any suggestions? I have used node update to no avail as yet.

You will have to perform a node add <ipaddress> 3000. So for example, if the address for the machine your processing node were running on were 192.168.0.22, you would issue node add 192.168.0.22 3000.

Yes have added the other computer & main computer, they show up in the cluster, but the laptop wont connect as per picy below. Also cant seem to get the cluster to connect into webodm. I have followed the missing guide, numerous google links and this site but nothing seems to work. Is there a walkthrough guide somewhere that goes through it in detail or should I just sign up for a computer science course at tech?
c1

If I run this winpty docker run --rm -ti -p 3000:3000 -p 8080:8080 opendronemap/clusterodm [parameters] says its all good but doesn`t show up in the http://localhost:10000 .If i run these commands it works.
git clone GitHub - OpenDroneMap/ClusterODM: A NodeODM API compatible autoscalable load balancer and task tracker for easy horizontal scaling ♆
$ cd ClusterODM
$ docker-compose up
can anybody tell me what is going on here?

So now I have all the nodes in the cluster, how can I tell if they are working? The other computers dont seem to registering any action in the task manager, shouldn’t they be spinning up a bit?
c1

It looks like one of the nodes has received a request. To test, send a lot of jobs to the cluster and wait. Sometimes it takes a few minutes for the jobs to show up in the individual queues.

1 Like

For posterity, I had this same issue on Windows 10.

You have to activate telnet with the -e flag if an escape character isn’t otherwise defined. I do:
telnet -e \ localhost 8080 which allows me to use the backslash to escape.

Then, from you Microsoft Telnet prompt you send commands like:
send NODE ADD some_ip_address 3000 and then hit enter to see the result. Then use escape key to return to the prompt.

Hope that helps.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.