ClusterODM Installation

Running AWS Linux 2 with Node 6.17.1 and npm 3.10.10. I’ve been running ClusterODM w/ Docker but wanted to try the installation. Executed npm install and got the below. In response I updated node-pre-gyp to @mapbox/node-pre-gyp. Based on another discussion site, I also made sure the 2 libcurl dev packages were installed and up to date. A direct install of node-libcurl gets the same result. It’s libcurl@2.3.3.

I’ve reached out to the libcurl community site without much luck yet. Curious if anyone here can spot this since it’s fairly catastrophic and probably obvious what I’m doing wrong to those more familiar with it.

npm WARN deprecated node-pre-gyp@0.15.0: Please upgrade to @mapbox/node-pre-gyp: the non-scoped node-pre-gyp package is deprecated and only the @mapbox scoped package will recieve updates in the future
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN prefer global node-gyp@7.1.0 should be installed with -g

node-libcurl@2.3.3 install /home/ec2-user/ClusterODM/node_modules/node-libcurl
node-pre-gyp install --fallback-to-build

node-pre-gyp WARN Using request for node-pre-gyp https download
node-pre-gyp WARN Tried to download(404): https://github.com/JCMais/node-libcurl/releases/download/v2.3.3/node_libcurl-v2.3.3-node-v48-linux-x64-glibc.tar.gz
node-pre-gyp WARN Pre-built binaries not found for node-libcurl@2.3.3 and node@6.17.1 (node-v48 ABI, glibc) (falling back to source compile with node-gyp)
gyp ERR! UNCAUGHT EXCEPTION
gyp ERR! stack /home/ec2-user/ClusterODM/node_modules/mkdirp/lib/opts-arg.js:7
gyp ERR! stack opts = { mode: 0o777, fs, …opts }
gyp ERR! stack ^^^
gyp ERR! stack
gyp ERR! stack SyntaxError: Unexpected token …
gyp ERR! stack at createScript (vm.js:56:10)
gyp ERR! stack at Object.runInThisContext (vm.js:97:10)
gyp ERR! stack at Module._compile (module.js:549:28)
gyp ERR! stack at Object.Module._extensions…js (module.js:586:10)
gyp ERR! stack at Module.load (module.js:494:32)
gyp ERR! stack at tryModuleLoad (module.js:453:12)
gyp ERR! stack at Function.Module._load (module.js:445:3)
gyp ERR! stack at Module.require (module.js:504:17)
gyp ERR! stack at require (internal/module.js:20:19)
gyp ERR! stack at Object. (/home/ec2-user/ClusterODM/node_modules/mkdirp/index.js:1:79)
gyp ERR! System Linux 4.14.248-189.473.amzn2.x86_64
gyp ERR! command “/usr/bin/node” “/home/ec2-user/ClusterODM/node_modules/node-gyp/bin/node-gyp.js” “configure” “–fallback-to-build” “–module=/home/ec2-user/ClusterODM/node_modules/node-libcurl/lib/binding/node_libcurl.node” “–module_name=node_libcurl” “–module_path=/home/ec2-user/ClusterODM/node_modules/node-libcurl/lib/binding” “–napi_version=3” “–node_abi_napi=napi” “–napi_build_version=0” “–node_napi_label=node-v48”
gyp ERR! cwd /home/ec2-user/ClusterODM/node_modules/node-libcurl
gyp ERR! node -v v6.17.1
gyp ERR! node-gyp -v v7.1.0
gyp ERR! Node-gyp failed to build your package.
gyp ERR! Try to update npm and/or node-gyp and if it does not help file an issue with the package author.
node-pre-gyp ERR! build error
node-pre-gyp ERR! stack Error: Failed to execute ‘/usr/bin/node /home/ec2-user/ClusterODM/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/home/ec2-user/ClusterODM/node_modules/node-libcurl/lib/binding/node_libcurl.node --module_name=node_libcurl --module_path=/home/ec2-user/ClusterODM/node_modules/node-libcurl/lib/binding --napi_version=3 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v48’ (7)
node-pre-gyp ERR! stack at ChildProcess. (/home/ec2-user/ClusterODM/node_modules/node-libcurl/node_modules/node-pre-gyp/lib/util/compile.js:83:29)
node-pre-gyp ERR! stack at emitTwo (events.js:106:13)
node-pre-gyp ERR! stack at ChildProcess.emit (events.js:191:7)
node-pre-gyp ERR! stack at maybeClose (internal/child_process.js:920:16)
node-pre-gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:230:5)
node-pre-gyp ERR! System Linux 4.14.248-189.473.amzn2.x86_64
node-pre-gyp ERR! command “/usr/bin/node” “/home/ec2-user/ClusterODM/node_modules/node-libcurl/node_modules/.bin/node-pre-gyp” “install” “–fallback-to-build”
node-pre-gyp ERR! cwd /home/ec2-user/ClusterODM/node_modules/node-libcurl
node-pre-gyp ERR! node -v v6.17.1
node-pre-gyp ERR! node-pre-gyp -v v0.15.0
node-pre-gyp ERR! not ok
Failed to execute ‘/usr/bin/node /home/ec2-user/ClusterODM/node_modules/node-gyp/bin/node-gyp.js configure --fallback-to-build --module=/home/ec2-user/ClusterODM/node_modules/node-libcurl/lib/binding/node_libcurl.node --module_name=node_libcurl --module_path=/home/ec2-user/ClusterODM/node_modules/node-libcurl/lib/binding --napi_version=3 --node_abi_napi=napi --napi_build_version=0 --node_napi_label=node-v48’ (7)
npm ERR! Linux 4.14.248-189.473.amzn2.x86_64
npm ERR! argv “/usr/bin/node” “/usr/bin/npm” “install”
npm ERR! node v6.17.1
npm ERR! npm v3.10.10
npm ERR! code ELIFECYCLE

npm ERR! node-libcurl@2.3.3 install: node-pre-gyp install --fallback-to-build
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-libcurl@2.3.3 install script ‘node-pre-gyp install --fallback-to-build’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the node-libcurl package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! node-pre-gyp install --fallback-to-build
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs node-libcurl
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls node-libcurl
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/ec2-user/ClusterODM/npm-debug.log

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.