ClusterODM fails to reprocess with --sm-cluster value

Hello all.

I’m running a ClusterODM with multiple nodes and processing tasks through the WebODM GUI.

I’ve got the cluster IP address set as the Processing Node in the WebODM GUI, and I also set the --sm-cluster value to the IP:port for the cluster. This setup has worked well and most jobs run to completion.

If a task fails, WebODM will fail to restart if the --sm-cluster parameter is formatted like 192.168.1.1:3000. You have to go back into the settings and reformat like http://192.168.1.1:3000. WebODM error message provides the format.

Has anyone else experienced this? I realize this is nitpicky, but it seems like if the input parameter succeeds in one case, it should also succeed when re-running.

Edit: I did fresh docker pulls for my cluster yesterday - so everything should be most recent.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.