Clearing queue on processing node?

#1

After installing the latest webODM through docker and messing around with it a bit, I now have a queue count of 13 on node-odm-1, and new tasks won’t run (status queued).

Access the web interface of the node directly shows 0 running tasks.

How do I clear the list? (or alternatively, how to start over, preferably without having docker download all the images again?)

Thanks,
Matt

0 Likes

#2

Duh… For future googlers/me:

./webodm.sh down
./webodm.sh start

fixes this!

1 Like

#3

How can the queue be reset on a native install too? Jobs seem to get ‘stuck’; they aren’t processing and webodm isn’t aware of them (other than the queue count from nodeodm).

0 Likes

#4

So the job is stuck in the nodeodm instance? At a guess, I’d try restarting the nodeodm job, but I’ve not seen that particular issue I’m afraid.

0 Likes

#5

That’s the thing, there’s no job to restart. It’s like the counter in the queue doesn’t get updated sometimes when a job finishes or dies. I’ve tried a reinstall/upgrade of the node but the issue remains. I’ve been through the API docs but there is no option to purge the queue (only display its size). Short of a complete system wipe, I don’t know what to try.

0 Likes

#6

The only time I’ve seen NodeODM hang and fail to update the queue is with this scenario. https://github.com/OpenDroneMap/ODM/issues/944 is that what you are seeing?

To reset the queue, just remove the contents of the data/ directory (folders and .json file) and restart NodeODM.

0 Likes

#7

Possibly, I was having pdal hanging issues - it seems to be extremely sensitive to the GCPs that it’s fed. I didn’t dig too deeply into each fault because I figured that I was using it wrong rather than it being a bug.

I managed to get the queue to zero by a combination of upgrading and rebooting - though I’ve tried both individually before and it hadn’t helped. I’ll keep the data/ trick in mind, thanks.

0 Likes