Change in point cloud quality after updating WebODM

I’m trying to process data from a repeat survey. We are collecting data at approximately quarterly intervals on the same site to measure changes, but I’m struggling to get good repeat results. I’m confident in the quality of both datasets, as the original images were collected with the same drone and are really nice and sharp.
The first dataset was collected and processed around June 2020. The second dataset was collected and processed this month, with the latest version of ODM. Unfortunately I don’t have the processing settings recorded from 2020.
I’ve been trying to work through the products to find where the issues are coming from, and I seem to be able to trace them all the way back to the point cloud. I’ve tried increasing pc-quality and feature-quality to ultra, as well as reducing pc-filter strength, but to no avail. I’d really appreciate any suggestions of what else I can do to obtain results like I used to!

Survey processed in 2020

Survey processed in 2021

Have you looked at bumping up the min-num-features and maybe expanding matcher neighbors (or doing no prematching what-so-ever)?

As a point of curiosity, could you reprocess the 2020 data alongside the above so we can see where it falls between the two?

Increase pc-quality to ultra. Also don’t resize your images. You’ll see big improvements.


Thanks for the help both. Unfortunately that 2021 result already had pc-quality set to ultra, with no resizing on the images.
I’m rerunning the 2020 set with current ODM now. I opted for the high-resolution preset, but tweaked the pc-quality to ultra.
Once that has finished running, I’ll have a look at the min-num-features and matcher neighbours options to see if I can make any improvements. Running on pretty reasonable hardware, so happy to max out the settings to hopefully get a better result!

1 Like

Sincere apologies guys… I ended up looking back at the raw images, and side by side comparison suggests that the 2020 data were collected at a lower altitude, (30m vs 40m) which perfectly explains the difference in the point clouds. If there’s any other settings I can tweak to get sharper reconstruction of the features then let me know, otherwise can consider this closed!


No worries! I can barely remember what happened yesterday, let alone flight plan details from a year ago :rofl:

Glad you’re sorted.

As for options, I think you’re pretty much on the path you need to be with feature-quality ultra, pc-quality ultra, min-num-features bumped up, no resizing, and either heightened matching or forcing no pre-matching.

I can’t tell without looking at the dataset, but if you have stuff that’s highly oblique maybe you could try masking background/sky to help cut down on noise in the point cloud?

Others also have manually pruned the point cloud externally and then passed that back in for processing with great results.

Try the --pc-geometric flag too for noise reduction.


I’ve begun playing with it, and it looks very promising!

Gotta A/B test it now.

1 Like

Reran the 2021 dataset with these settings…
dem-resolution: 1.0, dsm: true, feature-quality: ultra, ignore-gsd: true, min-num-features: 12000, orthophoto-resolution: 1.0, pc-quality: ultra
Still struggles a bit with some of the circled features, but much better than I got originally, and this isn’t actually in the main interest area, so can live with it!
Thanks again for the help.

1 Like

If you’re on the latest build/release, give the --pc-geometric flag a try :smiley:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.