Cell Tower Model Rendering Issues

Morning everyone,

I’m new to WebODM but our company has been doing cell tower work for a while now. Normally we have been able to get great 3D models by doing a TSO orbit at about a 60-70 degree angle. I have been testing all different profiles, quality settings, less images, more images but can’t seem to get a decent 3D model let alone a full model of the tower. I’ve cranked up quality to Ultra and this about the best I have gotten so far. Here are some examples of settings I’ve used. Any ideas on getting better results?

Test 1 auto-boundary: true, dsm: true, dtm: true, end-with: odm_dem, feature-quality: ultra, force-gps: true, mesh-size: 450000, min-num-features: 55000, pc-classify: true, pc-filter: 0, pc-geometric: true, pc-quality: high, pc-rectify: true, pc-tile: true, rerun-from: dataset, rolling-shutter: true, use-3dmesh: true

Test 2 - auto-boundary: true, mesh-octree-depth: 12, mesh-size: 300000, pc-filter: 0, pc-quality: high, use-3dmesh: true

Test 3 auto-boundary: true, dsm: true

2 Likes

1 Like

1 Like

Welcome!

Sorry for the trouble.

Are you ensuring you aren’t resizing the images when creating the Task?

Also, --pc-quality ultra might help a fair bit, same for reducing the --pc-sample threshold to something closer to your actual GSD.

Generally, more images will be better, provided they have good overlap/sidelap in the orbit.

Are you on a recent enough version to take advantage of our --bg-removal and --sky-removal flags for automated masking?

2 Likes

I have tried both ways with and without resizing. Have tried ultra. The tower model showed above was a total of 340 images. The building model was 1,205 images. I see that there is several options to select, just wasn’t sure if others have had luck with other settings. Normally, we do just the top only without about 40-60 images and can get some real nice models but this is without a clients modeling software.

1 Like

I’m unclear: have you tried with feature quality ultra and bg-removal enabled?

1 Like

I’m running a model right now with ultra and bg-removal enabled. Will let you know results.

2 Likes

21 hours later it completed. Top antennas show now, but rest of tower is gone.
auto-boundary: true, bg-removal: true, feature-quality: ultra, mesh-octree-depth: 12, mesh-size: 300000, pc-geometric: true, pc-quality: high, use-3dmesh: true

1 Like

I would drop --pc-geometric for now, and maybe set --pc-filter 0 as well. Can you process with --pc-quality ultra?

1 Like

So here’s the latest model. It looks better in point cloud, but textured most of it disappears. Tried it before you responded with the other options. This one took 30 hours because I wanted to test by CPU rendering.

auto-boundary: true, dsm: true, dtm: true, mesh-octree-depth: 12, mesh-size: 600000, min-num-features: 45000, no-gpu: true, pc-classify: true, pc-filter: 0, pc-geometric: true, pc-quality: high, pc-rectify: true, rolling-shutter: true, use-3dmesh: true

2 Likes

hate to do it, but bumping this thread - I don’t want it lost, as I’m experiencing a very similar issue. Paid for business-level and the processing time is abysmal, compared to Terra, but their 2D images stink as compared to Pix4D. Pix4D stinks with their 3D imagery. We just need WebODM to be the top dog here :slight_smile:

Have you had any luck with this? I seem to having the same problem with some tall pine trees.

Nothing yet. Been trying some other ways but still can’t get it to render fully. So far my best model of the building we mapped came out like this.

Water tower cell tower came out like this

1 Like

Well, at least you have that much. This image should have two 60-foot Jeffrey Pine trees in it, but doesn’t. You can clearly see the tree shadows, and the lack of snow under the canopy, but no trees. I’ve tried lots of different flight paths and capture settings, but still nothing. I’m stumped.

1 Like

Set your pc-filter value to 0. You can also try relatively small values, but start with 0. If you have enough photos to reconstruct, then setting this value will help you keep the point cloud filtering step from removing those trees.

2 Likes

That’s a little better. Now I get a blob that looks like part of one tree, but still nothing for the other one. I used pc-filter=0 and pc-quality=high.

2 Likes

Set your feature-quality to ultra, if your machine can handle it.

Also, take a look at the point cloud, it is likely much better looking than the mesh.

2 Likes

I managed to eventually get something reasonable, but still not great. It’s good enough for what I need, but I can see how this wouldn’t be good enough for a water tower.

I eventually settled on using pc-classify, pc-quality=high, pc-filter=0, sky-removal, resize=-1 for settings. Unfortunately I don’t have anything that can handle feature-quality=ultra.

FWIW, sky-removal doesn’t seem to do much at all. It helped a little, but only a little. In the image below you can still see a bit of sky in the tree texture.

1 Like

Can you please show the point cloud and also any settings you’re currently using? The mesh doesn’t tell much about the reconstruction itself so it’s hard to advise you on how to improve.

1 Like