Can't upload image to webodm hosted on a remote Ubuntu server

operating system ?
Operating system: Linux (ubuntu 18.04)

GPU: Standard NV4as_v4

RAM: 14 GiB

What is the problem ?
Hey guy. I uploaded webodm to a remote server on the cloud and whenever I try creating a task, uploading an image it exceeds the max number of retries and throws an error in the console.

But I tried this locally before pushing to the server it worked perfectly. Is there a problem with running webodm on a remote server? Cause I’ve tried every fix I could find on the community and other GitHub issues. I even deleted the server and rebuild it, re-upload webodm, and all. But the same issue

Log

worker      | [2020-09-20 16:28:14,141: INFO/ForkPoolWorker-1] worker.tasks.process_task[079448cc-47bb-45e7-9e74-74590915f809]: Canceling Task [Task of 2020-09-20T15:55:12.306Z] (ebac1776-32b1-4a3f-b2a9-21c4414f9bab)
worker      | INFO Removing Task [Task of 2020-09-20T15:55:12.306Z] (ebac1776-32b1-4a3f-b2a9-21c4414f9bab)
worker      | [2020-09-20 16:28:18,337: INFO/ForkPoolWorker-1] worker.tasks.process_task[91434748-2ec2-4c68-b4ed-57910123441d]: Removing Task [Task of 2020-09-20T15:55:12.306Z] (ebac1776-32b1-4a3f-b2a9-21c4414f9bab)
worker      | WARNING [Errno 2] No such file or directory: '/webodm/app/media/project/15/task/ebac1776-32b1-4a3f-b2a9-21c4414f9bab/'
worker      | [2020-09-20 16:28:18,341: WARNING/ForkPoolWorker-1] worker.tasks.process_task[91434748-2ec2-4c68-b4ed-57910123441d]: [Errno 2] No such file or directory: '/webodm/app/media/project/15/task/ebac1776-32b1-4a3f-b2a9-21c4414f9bab/'
webapp      | WARNING Not Found: /api/projects/15/tasks/ebac1776-32b1-4a3f-b2a9-21c4414f9bab/

What should be the expected behavior?
I expected the images to upload successfully and start processing

Google Drive Images
https://drive.google.com/file/d/18uvz35Vb1f1K0hHMfqhH29KIop-y7UDU/view?usp=sharing (error log)
https://drive.google.com/file/d/1ivRs9mzgzd8DeMPGgWLqMGkEjMHM9J4_/view?usp=sharing (browser error)

1 Like

Mm, very strange. I’m not sure, but WebODM was built with the idea of remote hosting in mind, so it’s not something that is restricted in the software.

2 Likes

Is there a recommended way of installing it on Linux? Cause what I did was clone the repo to the vm and started the application.

Docker image should be easiest to install/deploy

2 Likes

I noticed the webodm on the opendronemap docker hub repo is webodm_webapp and it’s a bash image. Is that the one?

Should be? I’m not terribly experienced with the docker images.

@pierotofy any help with this?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.