Can't process data after updating to ODM 0.9.8


I just updated one of my nodes and it now fails to process datasets it has successfully processed before.

It stops at 90% when Generating Overview Tiles:

The node itself is a LiveODM install and the WebODM-server is also a LiveODM install on another computer that is not yet updated.

I made the update with the commands found in How to update portable usb version of ODM installed onto Ubuntu 16.04

cd /code
git pull origin master
sudo bash reinstall

cd /www
git checkout package.json
git pull origin master
npm install

cd /webodm
git checkout package.json
git pull origin master

source python3-venv/bin/activate
npm install
pip install -r requirements.txt
webpack --mode production
python collectstatic --noinput
python migrate
bash app/scripts/
echo “from app.plugins import build_plugins;build_plugins()” | python shell

sudo chown -R odm:odm /code /www /webodm /home/odm

ODM v.0.9.1, API 1.5.3
200113_dataset -> fast ortophoto
Images: 231
Processing time: 00:35:58
Status: Completed
Created on: 2020-02-03 16:31:43
Processing Node: NOD1 (manual)
Options: fast-orthophoto: true

ODM v.0.9.8, API 1.6.0
200113_dataset -> fast ortophoto v. 0.9.8
Images: 231
Processing time: 00:49:01
Status: 63fb0676-2194-43a6-81e3-771aa41a14b0 not found
Created on: 2020-02-04 10:05:29
Processing Node: NOD1 (manual)
Options: fast-orthophoto: true

Is this the error message the task fails with? That’s odd, it’s as the task was removed before WebODM could download the results.

Does it work with other datasets?

Ah, I think it could be due to a program missing.

Install it via:

apt install -y p7zip-full

Then reboot.

Thank you for the input!

It kind of works, the only thing is that it takes forever to compress and fails like 50% of the time.

Seems a recurring problem. I’ve reverted compression to the legacy method, until this can be troubleshooted.

1 Like

I ran the same update script again and now it works! Thank you for the help @pierotofy