Can't cancel job

I have WebODM running on an Ubuntu machine and recently updated it with the WebODM Server Installer (rev 04/08/19). I don’t remember the rev prior to that but since I updated the server, I can’t cancel jobs. When I click on the cancel button, it never actually disappears. It shows “cancelling…” with the hourglass next to it.

Here’s a screenshot:

I’ve found that I can delete the entire project from the web interface, just not specific tasks. Has anyone else run into this and is there a way around that? I’ve gone into the folders to see if I can simply remove the specific folders but it’s difficult to determine which folders belong to specific projects/tasks.

Yes I have this problem regularly when cancelling or deleting tasks mid-upload or mid-process. I raised a bug report here that you may wish to contribute to:

If you restart the computer, are you able to get them unstuck?

No, they remain in the cancelling/deleting state. The only way to get them ‘unstuck’ is to delete the whole project.

I found after I updated to 1.0.2 i could restart the task. the task showed “Cannot cancel a task that has no processing node or UUID” but I could edit and restart.

I have canceled another task since the update to 1.0.2 and it is now stuck in “canceling”. the job was canceled during the upload to processing node.

Sounds a bit like, perhaps a duplicate.

Can you reproduce this consistently? If so, could you chime-in on the issue on GitHub with steps to reproduce this?

yes i think i can reproduce the problem. i believe it only applies to cancel. delete works fine last time i tried it.

i saw that the fix was rolled into the master a little while ago. i ran the installer on the WebODM server but the tasks are still showing canceling… is there i need to run to clear that message state so i can restart them? or do they have to be deleted and added back?