Cannot process dataset

Hi guys. I keep getting “Cannot process dataset” at around the 15 minute mark. I’ve used both DroneDeploy and Pix4D to plan my flight and acquire the images. The images do work when I use DroneDeploy to process them… Below is the tail end of my log file (not sure which part of the file is needed)…

Fused depth-maps 0 (100%, 0ms)
22:09:45 [App ] Densifying point-cloud completed: 0 points (5s203ms)
22:09:45 [App ] MEMORYINFO: {
22:09:45 [App ] VmPeak: 367200 kB
22:09:45 [App ] VmSize: 366008 kB
22:09:45 [App ] } ENDINFO
[INFO] running /code/SuperBuild/install/bin/OpenMVS/DensifyPointCloud --filter-point-cloud -1 -i “/var/www/data/46fad5a3-82dc-421c-b336-a6ada5e02e55/opensfm/undistorted/openmvs/scene_dense.mvs” -v 0
22:09:45 [App ] Build date: Jun 22 2021, 17:22:42
22:09:45 [App ] CPU: Intel(R) Core™ i7-7700HQ CPU @ 2.80GHz (2 cores)
22:09:45 [App ] RAM: 1.94GB Physical Memory 1024.00MB Virtual Memory
22:09:45 [App ] OS: Linux 4.19.76-linuxkit (x86_64)
22:09:45 [App ] SSE & AVX compatible CPU & OS detected
22:09:45 [App ] Command line: --filter-point-cloud -1 -i /var/www/data/46fad5a3-82dc-421c-b336-a6ada5e02e55/opensfm/undistorted/openmvs/scene_dense.mvs -v 0
22:09:45 [App ] error: empty initial point-cloud

===== Dumping Info for Geeks (developers need this to fix bugs) =====
Child returned 1
Traceback (most recent call last):
File “/code/stages/odm_app.py”, line 89, in execute
self.first_stage.run()
File “/code/opendm/types.py”, line 340, in run
self.next_stage.run(outputs)
File “/code/opendm/types.py”, line 340, in run
self.next_stage.run(outputs)
File “/code/opendm/types.py”, line 340, in run
self.next_stage.run(outputs)
[Previous line repeated 1 more time]
File “/code/opendm/types.py”, line 321, in run
self.process(self.args, outputs)
File “/code/stages/openmvs.py”, line 161, in process
system.run(’%s %s’ % (context.omvs_densify_path, ’ '.join(config)))
File “/code/opendm/system.py”, line 106, in run
raise SubprocessException(“Child returned {}”.format(retcode), retcode)
opendm.system.SubprocessException: Child returned 1

===== Done, human-readable information to follow… =====

[ERROR] Uh oh! Processing stopped because of strange values in the reconstruction. This is often a sign that the input data has some issues or the software cannot deal with it. Have you followed best practices for data acquisition? See https://docs.opendronemap.org/flying.html

1 Like

I have just had a successful completion having changed the option from ‘default’ to ‘high resolution’… any reason why that would be?

1 Like

Welcome!

Sounds like it was not finding sufficient tie points to reconstruct the data.

This could be due to a number of factors, normally related to how the data were collected.

Are you able to share the data somewhere like dronedb.app so we can take a look at it?

Sure. I will upload now.

I have tried to process again a few times using ‘High Resolution’, but now that’s not working either… I haven’t changed anything… strange.

1 Like

https://testhub.dronedb.app/r/lukevanderest/xyl2aiajfwekunve

1 Like

What gimbal angle were you using? It appears to be significantly under 90deg, but hard to tell on such small images.

1 Like

I used the ‘Enhanced 3D’ mode in Dronedeploy… so perhaps it changed the gimbal angle?

1 Like

I’ve found that the images that Dronedeploy does around the sides, taken at well under 90deg gimbal angles, work in DD’s processing, but are rejected in WebODM

1 Like

So maybe excluding the ‘Perimeter 3D’ option may help…

2 Likes

image

image

Options: cog: true, crop: 0, debug: true, dem-resolution: 1, dsm: true, orthophoto-resolution: 1, pc-classify: true, pc-geometric: true, pc-quality: high, use-3dmesh: true, verbose: true

lukevanderest-8122_Report - Reduced.pdf (773.1 KB)


It failed without pre-processing the images, but worked just fine after pre-processing them. I used the workflow described here:

1 Like

Could those image enhancements be done within the drone camera settings before flying the mission instead of doing it with another program after the flight? Extra contrast and sharpening?

1 Like

Very likely, but I’m not sure I’m comfortable making that a blanket recommendation since you could get yourself into trouble with that.

In my mind, it’s pretty cheap/easy to pre-process the data to make it work, but if you have bad settings when you collect, there isn’t much you can do to save that data after the fact.

1 Like

Success in processing - however the image turned out skewed?sdfgfdsg

1 Like

Super odd! What processing parameters did you use?

Can you attach your Report pdf?

1 Like

I used your same parameters…report (1).pdf (8.4 MB)

1 Like

Hmmm…
Did you pre-process them or use GCPs?

I don’t know what would cause that distortion and shift.

Your position accuracy is so low compared to when I processed it!

Pre-processed in XnConvert using enhance and contrast… could have that program changed something else?

Shouldn’t have… It didn’t here :thinking:

What Output settings did you have?

I’ve re-processed it, but this time using Chrome web browser. I accidently used Firefox for that last one. Not sure whether that was the issue or not, but it has processed fine now.

Thanks so much for your help!

1 Like

Shouldn’t have mattered, but who knows! Crazy things happen, haha.

Glad you’re sorted!

1 Like