Cannot create new task

grab-1
It seems no matter what I do inc rolling back version or upgrading to the latest resolves this. Any ideas what is stopping a new task from being created?

1 Like

Welcome, David!

Sorry to hear you’re having trouble creating new tasks.

Are you able to try deleting the tasks.json file by using the Tools → Reset Processing Queue menu item on the latest version of WebODM for Windows (native)?

Thanks. Yes that was the first thing I tried. It is the windows native version

On running now I am getting these errors
Screenshot_20210710-162905_Remote Desktop|690x323 Screenshot_20210710-162613_Remote Desktop
And the log shows stalling at postgres authentication and timing out
Screenshot_20210710-163645_Remote Desktop

Are you able to uninstall it, and then manually delete the entire C:\WebODM directory and any contents that may be left-over, and then re-install from the latest installer?

Complete fresh install now
Originally I installed it on a different partition (E). Wondering if the update process changed that and left some references to the wrong place. A different problem now I suspect.

Still won’t run. App log:
“Attempt 9 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: psql: server closed the connection unexpectedly\r\n\tThis probably means the server terminated abnormally\r\n\tbefore or while processing the request.\r\n”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: the database system is in recovery mode\r\n”
“C:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
{}

pgsql log:
FATAL: relation mapping file “global/pg_filenode.map” contains invalid data
LOG: autovacuum launcher process (PID 14800) exited with exit code 1
LOG: terminating any other active server processes
LOG: all server processes terminated; reinitializing
LOG: database system was interrupted; last known up at 2021-07-10 15:03:40 EDT
LOG: database system was not properly shut down; automatic recovery in progress
LOG: invalid record length at 0/E0399F8: wanted 24, got 0
LOG: redo is not required
LOG: MultiXact member wraparound protections are now enabled

Do you have the Docker version installed still? Do you have any other PostgreSQL server instances running on that machine?

No other PostgreSQL that I can see. I have also removed the Docker version

1 Like

Are you using an antivirus product other than Windows Defender?

Is this a personal or managed device?

Avira. I have disabled it with no joy. Also white listed postgres and webodm in that and Defender.
It isn’t a managed device

1 Like

Hmm… Can’t think of what would block it at this point. Do you know how to do an In-place upgrade or repair install