Boundary Settings

Hi,
please find the dataset:

https://drive.google.com/drive/folders/1qaeXi-qp-kHadcqgvsMcCooUXtt87Ckq?usp=sharing

I am trying to use the boundary settings and do some experiments. I have randomly drawn a polygon around the images and tried to process but eventually ended up with the following error:

[ERROR] Uh oh! We ended up with an empty point cloud. This means that the reconstruction did not succeed. Have you followed best practices for data acquisition? See https://docs.opendronemap.org/flying/. Also, since you used a boundary setting, make sure that the boundary polygon you specified covers the reconstruction area correctly.

Do I need to be precise enough to draw the polygon? If yes, is it not possible to reconstruct as much as possible within the polygon specified. It may not even cover the whole polygon.

Or am I missing something while drawing the polygon? I have attached processing log too.

2 Likes

I’ve found that for subjects such as small buildings that the errors in (I assume they use) Google Maps means that the coordinate json file may not actually correctly cover the subject. I discovered this recently when I drew a polygon with about 5m clearance around a building, but ended up with only about half the building in the PC and ortho.

2 Likes

I used a different dataset with following parameters:
auto-boundary: true, boundary: {"type":"FeatureCollection","features":[{"type":"Feature","properties":{},"geometry":{"type":"Polygon","coordinates":[[[73.04245950290222,28.01878874299666],[73.04166385765821,28.01847145237983],[73.04081456823394,28.018873985092604],[73.04079311056182,28.018431070489047],[73.04069655103729,28.01797870158106],[73.04171213742048,28.017519333979106],[73.04265262195129,28.01798817299968],[73.04257752009887,28.018383721330345],[73.04245950290222,28.01878874299666]]]}}]}, crop: 0.01, dem-resolution: 1, dsm: true, dtm: true, mesh-size: 350000, min-num-features: 24000, orthophoto-resolution: 1, pc-filter: 0, pc-geometric: true, rolling-shutter: true, rolling-shutter-readout: 17

I have got a perfectly cropped 3D Model according to the cropped boundary but orthomosaic is not cropped properly.


3D Model

orthomosaic
Orthomosaic

Is there a probable bug?

I have cropped it manually for now. After cropping, it should like this.

It is expected behavior (it returns a convex hull for the aerial which is a safer approach) though clearly for your use case it isn’t desirable behavior. So I would characterize this as a feature request.

1 Like

Instead of using convex hull, we can directly use the points present in boundary parameter. I guess we are doing the same thing during 3D Model cropping because I got the exact cropped result as I was expecting.

I am just curious to know about the cropping workflow also. Are we cropping the sparse point cloud or are we generating the whole set of results, like Dense Point Cloud, 3D Model, DSM, DTM and Orthomosaic and then we are cropping them individually?

1 Like