Blank Orthophoto and map tiles for very close up images of ground field (~0.05 cm/pixel GSD)

Cool. Thanks for continuing the conversation here. So, when you run with 0.05 and `–ignore-gsd``` you can’t see it in the web viewer. Can you download the ortho and view it in e.g. qgis.org?

Thanks @smathermather-cm. I tried opening the downloaded orthophoto in QGIS and it also shows just white blank output. Please note that the generated orhtophoto.tiff size is ~700 KB

Any chance you can share the raw jpegs via google drive or similar?

Yes definitely. https://drive.google.com/file/d/1l3X7yVD6XuNg1g-laLBsKb9Uhsuz-mdW/view?usp=sharing

Please note that its only first 10 images from the large dataset of 4500 images.

1 Like

It’s probably better to share ~40 images all in one cluster. The first 10 images are unlikely to successfully reconstruct.

I think what I’m experiencing is the same behavior; although, I have not changed any settings yet. I was going to set the orthophoto-resolution but it sounds like it doesn’t change anything. See what I’m seeing here:

@ankit is this what you’re experiencing?

I’m working with 349 images. Used a DJI P4 RTK to capture them. The RTK had a constant FIX on 22-23 satellites.
Options: orthophoto-png: true, dsm: true, verbose: true

Hi @smathermather-cm Here is the link to 41 images from the dataset. I tried with first 40, first 300 but same results. Blank orthophoto and blank tile images. Please suggest. Also, I have configured the code to generate tiles till 30 zoom.

@uametry For me the orthophoto and tiles are completely blank and in file size of bytes or Kbs which should be impossible if the generated output is correct

A set of 40 in sequence won’t do the trick: they need to be related to each other, i.e. clustered around a common area. This appears to be a sequence instead of a cluster:
image

If you are able to share the entire dataset, that might be easier for us both.

That said, I suspect the issue with generating an orthophoto has much to do with the precision of the GPS relative to the resolution at which you are working. For 40 images, I only see 23 unique locations, and we can see there’s some rounding errors in the positions – see how those positions follow a grid pattern? I suspect that’s due to a precision limitation in the data.

In short, your geographic information isn’t good enough to inform how to create an orthophoto relative to the resolution that the data are collected at. To put it another way: the imagery is amazing; the GPS is not good enough to match.

What kind of GPS are you using? Is it an RTK or PPK solution with sub-centimeter accuracy? That’s what you need if you are collecting sub-centimeter resolution imagery. There are ways around this, if you gather enough imagery over a large enough area, the GPS problems tend to wash out, but for a small area, high resolution, with poor GPS, there are limits to what we can extract.

1 Like

I have seen empty orthos as well, though not for very low altitude images.
Couldn’t resolve that specific case