Best practice for ortophoto RGB

Hi @all,
i’m police officer from germany. Since last year i’m working with a parrot anafi work in the case of traffic accidents. The following worklflow works pretty nice for us. In case of traffic accidents with hardly injured or even dead person we are mapping the accident site with the anafi. Flight high depends on ground but is mostly 20m above ground, nadir photos.
For stitching the foto into orthomosaic i’m using pix4Dreact. This works pretty good and the result is a very good zoomable orthophoto.
I now want to use the webodm for that case. So i tried it many times with different options in webodm. The problem is that i cant reproduce similar orthophoto like pix4dreact.
the resolution between pix4dreact and webodm ist different, in webodm smaler. The same for the size of the ortophoto. When using the same photos for stitching the size of the orthophoto in webodm is aprox. 440mb in pix4dreact 1,2GB.
If i zoom into both photos the quality of webodm isn’t that good as pix4dreact. But we need to zoom in for reconstruction purpose.

Is there a best practice for getting the highest quality for orthophoto?
Sample:
pic

greetings from germany Ronny :upside_down_face:

2 Likes

Very interesting application.

  1. Make sure you are not resizing your images when uploading a task.
  2. Make sure ignore-gsd is checked from the task options.
  3. Decrease orthophoto-resolution from task options.

@pierotofy
Thanks for your reply…

Problem:
[Task of 2020-08-01T11:56:31.569Z]
In WebODMLightning Windows i choosed the following options:
Options:
min-num-features: 280000,
resize-to: -1,
orthophoto-resolution: 1.0,
dem-resolution: 1.0,
orthophoto-compression: NONE,
dsm: true,
camera-lens: brown,
depthmap-resolution: 1000,
texturing-data-term: area

In WebODM same Task he showed the following:

{“uuid”:“5c58bc9b-99cc-4f21-a71e-99bcdabcb6aa”,“name”:“Task of 2020-08-01T11:56:31.569Z”,“dateCreated”:1596285463934,“processingTime”:7336166,“status”:{“code”:40},“options”:[{“name”:“min-num-features”,“value”:10000},{“name”:“resize-to”,“value”:2048},{“name”:“pc-sample”,“value”:0.01},{“name”:“orthophoto-resolution”,“value”:1},{“name”:“dem-resolution”,“value”:1},{“name”:“orthophoto-compression”,“value”:“NONE”},{“name”:“optimize-disk-space”,“value”:true},{“name”:“dsm”,“value”:true},{“name”:“camera-lens”,“value”:“brown”},{“name”:“depthmap-resolution”,“value”:1000},{“name”:“texturing-data-term”,“value”:“area”}],“imagesCount”:97,“progress”:100,“output”:[]}

The Options i chose in webodm Lightning in Windows have partly been ignored :roll_eyes:.
I dont know why.
I also can not find the “ignore_gsd” in the options.

greets Ronny :slightly_smiling_face:

Ah, didn’t know you were using lightning.

ignore_gsd is not available on lightning (because of performance reasons). You will have to run a processing node locally to use that option and get the resolution results you’re looking for.

@pierotofy
OK thanks for your reply.
Thats pretty bad because i dont have the hardware to do so. Only have a Laptop :roll_eyes:
I dont think this could work for 600 pics and full settings.

I hoped that i could use a managed plan, pay some euros and everything works fine…

Ok… Thanks @pierotofy

2 Likes