Artifacts in WebODM, Pix4D does it better, how do I get that result in WebODM?

Processed some images of my house with the preset “buildings”:

Result with WebODM:

Processed it also with Pix4D:

In the WebODM result, the roof lines are not straight and some artifacts are clearly visible.
In the Pix4D result, rooflines are nice and clean (mostly).

How can I get the same result in WebODM?

Options used in WebODM:
Options: mesh-octree-depth: 10, mesh-size: 300000, depthmap-resolution: 1000, texturing-nadir-weight: 28

I haven’t done residencial areas yet, but i’ve noticed that if you add texturing-nadir-weight:32 and texturing-data-term:area that it generally flattens things out.

Thanks I will try those options. I’ll let you know!

Hello! Have you solved this problem?

Nope its even worse with the options: exturing-nadir-weight:32 and texturing-data-term:area

1 Like

And how well did it do in preset “fast-orthophoto” ? If you didn’t try yet …

If you look closely, the image from pix4d is slightly different in terms of imagery which suggests that, like precisionmapper, they both “treat” the photo with some kind of features that we don’t know about.
I’ve been doing some experiments and it looks like if the levels on the photos, aren’t “inside some kind of parameters”, for example mine (I overexposed the photos on purpose):
node-odm-1:3000 (auto)

Screenshot_2019-05-14_08-30-13
Options: texturing-nadir-weight: 32, mesh-size: 10000, opensfm-depthmap-min-consistent-views: 2, fast-orthophoto: true, texturing-data-term: area, depthmap-resolution: 100, rerun-from: dataset

my webodm runs out of memory when doing a “high-resolution” setting.
I’m going to share the dataset and ask on the webodm category.

options: fast-ortophoto:
webodm-fast

Options: texturing-nadir-weight: 32, mesh-size: 10000, opensfm-depthmap-min-consistent-views: 2, fast-orthophoto: true, texturing-data-term: area, depthmap-resolution: 100, rerun-from: dataset:

webodm-custom

So at this moment the default option setting “buildings” give the best result so far. But Pix4d is a lot better in straight roof lines so far.

Who has the solution (designer, programmer or user)?

If you share the dataset I could process it with a few different options and see what comes out best.

Well if you can give a help!!

http://elitua.dyndns.org/drone/ds1.zip
http://elitua.dyndns.org/drone/sv1.zip

I appreciate it!

Kind Sir, I think i have figured it out. please try the following options:

step 1: loading your dataset;
step 2: choose Fast-Orthophoto;
step 3: choose edit and change the following Options: using the edit button;

texturing-nadir-weight: 17,
orthophoto-resolution: 1,
dem-resolution: 1,
mesh-size: 10000,
fast-orthophoto: true,
opensfm-depthmap-method: BRUTE_FORCE,
use-hybrid-bundle-adjustment: true,
rerun-from: dataset

To try and adapt to a rooftop dataset, if these changes don’t improve, try lowering still the option:

mesh-size to something like 5000

WORD!!

PS: let us know how it works out

2 Likes

Can you try to get the best result with my test dataset as well? Thanks!

Does not work very well for my dataset:

try01

In the meanwhile lower the mesh-size to something like 2000 and keep the rest.
You area is much smaller than mine!

I will download and give it a try on my setup!

HEAD’s UP!!!

(it’s like four with golf but now it’s for drones!!! :stuck_out_tongue_winking_eye: )

Any update(s)?

Hi there!
I decided to experiment with this problem.

I made a flight with 30% overlap on front and side.
Then processed with:
Options: use-3dmesh: true, texturing-nadir-weight: 28, orthophoto-resolution: 2.0, dtm: true, dem-resolution: 2.0, ignore-gsd: true, orthophoto-cutline: true, dsm: true, depthmap-resolution: 2000, use-fixed-camera-params: true, rerun-from: dataset

and it’s the best orthophoto so far.

no waves, straight lines, trees look stupid but in urban areas it looks great.

1 Like