Always Exception: Child returned 139 - even after often settings change

#1

Hello!

I know that the Title of the topic looks like that it is already often discussed. I was trying several things and settings but at the end I am not anymore able to produce ANY Model nor DTM DSM etc. It always cancels at the Structure From Motion / MVS.

At the beginnig of using WebODM already one year ago everything went fine. The only thing what really Changed was that I deinstalled the whole bunch of Docker, Oracle and WebODM some months ago because I had some issues with a VPN-Network (what didn’t work anymore after using WebODM) and I installed it again maybe two months ago because I want to give it a second try. The VPN is now working good even when WebODM is running. But I am not anymore able to produce any output. I higher the memory of the virtual machine, higher the min-num-features several times used also other different settings (higher and lower) on different batched of Drone pictures. Now I really want to use the software again, updated several times again and again but it’s again (again) the same error “Child returned 139”

Luckily now I have a project which I can share with you outside of my university research tasks and to give you the picture via Dropbox.

LINK: https://www.dropbox.com/sh/wrrkxca4jmmzsjk/AAA1l9B1ISp4pzGSJUApdvOga?dl=0

There is also the Output of the Console (which I now always enable at verbose setting to may get a more complete look into the problem) in a .txt File - shall I copy it here again?

Anyway PLEASE help me.

My computer setting:

Win 7 Pro x64 (might there be a issue that it’s not Win 10 now because of the updates?)
32Gb Ram
AMD FX 8120
Nvidia Quadro K5000
SSDs and HDDs

Tnx in Advance,

Alex

0 Likes

#2

A copy of the console output would be most helpful.

0 Likes

#3

Ah, found it the output.

2019-03-24 11:47:03,409 INFO: Adding DJI_0230.JPG to the reconstruction
2019-03-24 11:47:03,669 INFO: Re-triangulating
Segmentation fault (core dumped)

This is a difficult one to troubleshoot. It doesn’t really indicate why it fails.

You said it doesn’t work even with a smaller subset (like, 10-20 images)?

0 Likes

#4

Hallo!

Tnx for the answer.

No I tried and it’s always this 139 - the last try was two hours ago. But I was able to make quite good models at the begin of the use of WebODM - I also tried the same pictures from that time alomost one year agao and to reproduce the that time very nice output but it is not reaching the end of the Structure From Motion / MVS reconstruction again with the same set of pictures.

Alex

0 Likes

#5

Okay after updating again (see other post) I tried again with the same set and following (different?) result appered:

  • 2019-03-25 09:12:42,081 DEBUG: Found 19356 points in 19.3976299763s
  • 2019-03-25 09:12:43,532 INFO: Extracting ROOT_HAHOG features for image DJI_0363.JPG
  • 2019-03-25 09:12:43,771 INFO: Extracting ROOT_HAHOG features for image DJI_0331.JPG
  • 2019-03-25 09:12:44,013 DEBUG: Found 18789 points in 18.6037199497s
  • 2019-03-25 09:12:44,214 DEBUG: Found 19185 points in 18.8019399643s
  • 2019-03-25 09:12:46,041 INFO: Extracting ROOT_HAHOG features for image DJI_0246.JPG
  • 2019-03-25 09:12:46,184 INFO: Extracting ROOT_HAHOG features for image DJI_0223.JPG
  • 2019-03-25 09:12:47,889 INFO: Extracting ROOT_HAHOG features for image DJI_0405.JPG
  • 2019-03-25 09:12:48,580 INFO: Extracting ROOT_HAHOG features for image DJI_0216.JPG
  • 2019-03-25 09:13:03,524 DEBUG: Found 18479 points in 19.8222241402s
  • 2019-03-25 09:13:03,686 DEBUG: Found 19175 points in 19.7202599049s
  • 2019-03-25 09:13:06,205 DEBUG: Found 18931 points in 19.9870731831s
  • 2019-03-25 09:13:06,952 DEBUG: Found 19352 points in 20.599601984s
  • 2019-03-25 09:13:07,365 INFO: Extracting ROOT_HAHOG features for image DJI_0327.JPG
  • 2019-03-25 09:13:07,687 INFO: Extracting ROOT_HAHOG features for image DJI_0474.JPG
  • 2019-03-25 09:13:08,723 DEBUG: Found 19000 points in 20.6267800331s
  • 2019-03-25 09:13:09,835 DEBUG: Found 19657 points in 21.0471718311s
  • 2019-03-25 09:13:10,042 INFO: Extracting ROOT_HAHOG features for image DJI_0292.JPG
  • 2019-03-25 09:13:10,918 INFO: Extracting ROOT_HAHOG features for image DJI_0279.JPG
  • 2019-03-25 09:13:13,192 INFO: Extracting ROOT_HAHOG features for image DJI_0380.JPG
  • 2019-03-25 09:13:13,978 INFO: Extracting ROOT_HAHOG features for image DJI_0241.JPG
  • 2019-03-25 09:13:26,262 DEBUG: Found 19231 points in 18.7188699245s
  • 2019-03-25 09:13:27,721 DEBUG: Found 19285 points in 19.8591389656s
  • Traceback (most recent call last):
  • File “/code/SuperBuild/src/opensfm/bin/opensfm”, line 34, in
  • command.run(args)
  • File “/code/SuperBuild/src/opensfm/opensfm/commands/detect_features.py”, line 30, in run
  • parallel_map(detect, arguments, processes)
  • File “/code/SuperBuild/src/opensfm/opensfm/context.py”, line 38, in parallel_map
  • return list(e.map(func, args))
  • File “/usr/local/lib/python2.7/dist-packages/loky/process_executor.py”, line 794, in _chain_from_iterable_of_lists
  • for element in iterable:
  • File “/usr/local/lib/python2.7/dist-packages/loky/_base.py”, line 589, in result_iterator
  • yield future.result()
  • File “/usr/local/lib/python2.7/dist-packages/loky/_base.py”, line 433, in result
  • return self.__get_result()
  • File “/usr/local/lib/python2.7/dist-packages/loky/_base.py”, line 381, in __get_result
  • raise self._exception
  • loky.process_executor.TerminatedWorkerError: A worker process managed by the executor was unexpectedly terminated. This could be caused by a segmentation fault while calling the function or by an excessive memory usage causing the Operating System to kill the worker. The exit codes of the workers are {}
  • Traceback (most recent call last):
  • File “/code/run.py”, line 47, in
  • plasm.execute(niter=1)
  • File “/code/scripts/run_opensfm.py”, line 118, in process
  • (context.pyopencv_path, context.opensfm_path, tree.opensfm))
  • File “/code/opendm/system.py”, line 34, in run
  • raise Exception(“Child returned {}”.format(retcode))
  • Exception: Child returned 1
0 Likes

#6

Huhu!

So I guess there is no solution avaiable or tips what can I try?

Thank you very much but what could be the issue? O.O

0 Likes

#7

@AlexNoir – have you tested this with datasets that are known to consistently work, e.g the bold formatted ones at https://github.com/OpenDroneMap/ODMData?

0 Likes