Aligning submodels - ODM native Windows

My computer has the following specifications:

  • Intel(R) Core™ i5-3570K CPU @ 3.40GHz 3.80GHz
  • 24GB RAM 1600MHZ
  • SSD 500GB
  • Windows 10 Pro 64bits

I successfully processed 750 images in the default configuration (without specifying any flags):

run C:\Users\Felipe\datasets\project

Then I tried to process the same dataset only now incrementing some flags and using --split and --split-overlap:

run C:\Users\Felipe\datasets\project --build-overviews --cog --dem-resolution 10 --dsm --dtm --feature-quality high --ignore-gsd --merge all --mesh-octree-depth 11 --mesh-size 20000 --min-num-features 8000 --orthophoto-cutline --orthophoto-kmz --orthophoto-png --orthophoto-resolution 7.0 --pc-geometric --pc-las --pc-quality medium --pc-tile --split 200 --split-overlap 100 --time --verbose --debug

but the process always stops at that point. “[INFO] Aligning submodels…”.

I was thinking that the processing was dying for lack of RAM, so I reduced the dataset to 112 images, set the –split 30 –split-overlap 50 and ran the command again, but the problem persisted.

If I remove the –split and –split-overlap flags the processing completes successfully.

What can I be doing wrong?

1 Like

Maybe colliding with pc-tile?

I removed the --pc-tile option and it always stops at that point.

I tested it with the default configuration and also the process ends in “Aligning submodels”

1 Like

Are you able to share the data?

Certainly. Thank you so much for your help.
Here is a link with the data: dataset - Aroazes_frd

1 Like

Don’t thank me yet, I don’t know if I can figure this out :rofl:

First look: Way under-exposed. I’m going to pre-process the images and try running them.

1 Like

Here is another dataset (dataset - Caxias) from another area and with better exposure, better lateral and longitudinal overlap, and also better 4 cm/px spatial resolution.

1 Like

Is this one also giving you the same trouble, or nah?

1 Like

Yes, same problem.

I have not taken the time to share it yet but the few tests I have made on native Windows give me the same results for Split-Merge.

Stuck at “Aligning submodels…

I though I was doing something wrong but had no time to check it for now (buzzy with the auto-gcp feature).

Will follow this thread with attention.


WebODM Lightning:

Options: build-overviews: true, cog: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 1, dsm: true, mesh-size: 300000, min-num-features: 12000, orthophoto-resolution: 1, pc-classify: true, pc-ept: true, pc-geometric: true, pc-quality: high, use-3dmesh: true, verbose: true

My personal PC is pretty similarly specced, so I’ll try with your settings above now, but with my pre-processed images to see what I can make of it now that I’m confident the data can reconstruct.

WebODM Lightning Split/Merge:

Processed just fine.

1 Like
Options: cog: true, debug: true, dem-resolution: 1, dsm: true, dtm: true, orthophoto-cutline: true, orthophoto-kmz: true, orthophoto-png: true, orthophoto-resolution: 1, pc-geometric: true, pc-las: true, pc-tile: true, rerun-from: dataset, split: 30, split-overlap: 100, use-3dmesh: true, verbose: true

Alright, getting this error: Processing failed (3221225477)

2021-08-01 21:50:45,991 INFO: Reconstruction 0: 34 images, 21373 points
2021-08-01 21:50:45,992 INFO: 1 partial reconstructions in total.
[INFO]    Aligning submodels...

Cursory search seems to indicate a memory allocation issue in native code somewhere:

1 Like

I’m having the same problem. Stuck at “Aligning submodels…” stage. I am processing a dataset of 2500 images with the following options. My workstation has 48GB RAM. The process went fine if it is run without split and merge.

Options: build-overviews: true, debug: true, dem-decimation: 2, dem-euclidean-map: true, depthmap-resolution: 980, dsm: true, dtm: true, matcher-distance: 5, mesh-size: 1000000, min-num-features: 10000, orthophoto-cutline: true, pc-classify: true, pc-ept: true, pc-geometric: true, pc-quality: high, pc-rectify: true, pc-tile: true, smrf-threshold: 0.3, smrf-window: 25, split: 750, texturing-data-term: area, texturing-tone-mapping: gamma, tiles: true, use-exif: true, use-hybrid-bundle-adjustment: true, verbose: true

1 Like

Maybe try dropping the depthmap resolution (superceded by pc-quality) and the hybrid bundle adjustment?

Also, what’s your split-overlap? I don’t see it in your parameter list.


Thank you for pointing out the depthmap-resolution flag. In fact, the process went okay if I removed split and merge as I said above. It gave me the same exit code ‘3221225477’ with split-and-merge options. May be it needed to be fixed at the native code level.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.