Add GCP File- Error- Cannot Process Dataset

Link to Images, GCP File and Console Output

https://1drv.ms/u/s!AhsRj4fHzB7Q3yYc0BQCiETh-9I8?e=NwBJMA

No fine tuning- though I have tried various preset settings to make sure it wasn’t some simple parameter causing my problem.

I am fairly new to WebODM but I have been testing it extensively over the past month. I have tested this multiple times with various datasets and trying various preset settings. The datasets will process perfect, every time without a GCP file but errors out each time I add a GCP file. I have tried reading about how to do this properly, recreated the GCP files numerous times with various datasets.

I was using the built in GCP editor in WebODM but did run across a post suggesting that someone had success with a similar problem to mine with the GCP Editor Pro plugin- so I bought it, impressed with the improved workflow but it did not solve my problem.

I have tried tagging more and less GCP after reading that it can be overdone (too many GCPs) following the minimum of 5 points in 3 or more photos rule. The GCP file in the folder has 10 spread throughout the area.

I obviously think I am doing something wrong with GCP but am stuck- I am humbly asking for your expertise.

Specs for Processing Environment

Installed with WebODM windows installer.
WebODM 1.9.14- this version is used on both my desktop and my processing node.

I use a Windows 11 VM Desktop for the frontend.
I have a processing node setup on a Windows 10 VM with 8 cores assigned and 16gbs RAM.

1 Like

If you do not have a Z measurement for your GCP’s use a 0 instead of NaN. Have seen it cause issues before.

3 Likes

Thank you for your response- I tried what you recommended and this corrected the issue.

It is frustrating that in the GCP Editor Pro the documentation states “Elevation values can be set to “NaN” to indicate no value” and that is how it creates the file in the automated process. What would be the appropriate way to request that a change be made to the tool so that it creates the files in the proper format?

image

1 Like

You can file an issue on the GitHub for it, or I can make one and hopefully tackle it shortly.

Whichever you prefer :slight_smile:

I’ll throw it out there, good for me to learn my way around on here- thank you both for the help. Just wanting to make sure put it in the most appropriate place to be addressed. After seeing the results with GCPs it seems like it dramatically increases the accuracy of the data.

1 Like

Thanks for your contribution!

Yeah, they’re quite powerful, especially when you use higher-accuracy methods like in-situ GPS collection with long-baseline, PPK, or RTK.

Just to add a bit to this, having high precision gcp’s with the vertical data helps with elevation models in that ODM uses that data to determine elevation and not have to rely on EXIF data from your images being correct.

1 Like

I am using the GCP Editor Pro which default is Google Maps and I assume it does not have elevation data is why it throws NaN in the file. I can do some searching but do you all know of a good online source for the accurate elevation data? Just making assumptions but thinking that if it is not highly accurate it could have the opposite effect on the processing. I saw Saijin’s post but unfortunately I currently do not have a high accuracy GPS which I think the things he is describing are various forms of gathering that data with that type of device. (I obviously have a lot of learning to do)

1 Like

I have used USGS service. you can input a lat lon and it will zoom to that coordinate on a map and have info on elevation and other info.

1 Like

You can also use long-baseline sampling with something like GPSPoint:

If you have (at least) a minute, it makes a huge difference over single-reading accuracy.

Another good one that I use is SW maps, i know its available for android however I do not believe there is a ios version. http://swmaps.softwel.com.np/
it will average location same as gps point but you can add a geoid file to get orthometric elevation instead of the ellipsoid elevation and export your data into shapefile,excel,kmz/kml,geojson,csv,gpkg. Also if you ever do get a RTK receiver you can use this with it for high precision. Have Fun!!

2 Likes

GPS Point doesn’t appear to be available on Google Play

The requested URL was not found on this server

and searching doesn’t find it either.

I wonder if it really is any better than the rest of the averaging apps, which from my tests still have day to day errors of 3-4metres, despite showing errors of under 1m when averaged over several hours.

1 Like

Interesting. When I was up on research on GPS averaging a few years back, we could get sub-decimetre within 30 minutes or so, but it probably depends heavily on your available constellation.

2 Likes

Yeah, looks like it has been taken down recently. I’ll poke around and see why.

In my limited testing it returned the best results. To be fair, I also forced GPS Duty Cycling OFF which helps a fair bit. If you have Developer Mode enabled for your Android it might be worth experimenting with your averaging apps when using that (aware that there will be an attendant drop in battery life while using GPS).

Commodity-grade Android phones, or external antenna/GPS units? I’ve never tried averaging with even semi-good hardware (unless a Garmin eTrex counts).

1 Like

Yes, I did that with the 4 or 5 I tried, and attached an external battery :wink:

Tests against averaging over several hours with my cycling Garmin 805 did not show any convergence, there were always differences of several metres, so you never know which one to believe!

I am thinking about an Emlid M2 at some stage, for GCPs.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.