2d Model is fine / 3d Model Blank

New WebODM user here… Ran my first project with ~300 pictures using Lighting. 2D model displays fine, but 3D model is blank. I ran the developer tools and noted asset errors, but not sure how to correct. Any help would be appreciated.

1 Like

Did you save the processing log?

Unfortunately, it looks like Lightning doesn’t save the processing log. I can access the resulting files for 14 days, but no console log as I can tell. I have the georeferencing log available, but not sure if that’s helpful.

1 Like

Sure, any details you have will help greatly.

Georeference Log:

Arguments given

Reading cameras from: /var/www/data/a7320b6c-bee6-4f4e-a986-ab048f6e4124/opensfm/bundle_r000.out
Reading transform file from:
Reading cameras gps exif positions from: /var/www/data/a7320b6c-bee6-4f4e-a986-ab048f6e4124/odm_georeferencing/coords.txt
Reading textured mesh from: /var/www/data/a7320b6c-bee6-4f4e-a986-ab048f6e4124/odm_texturing/odm_textured_model.obj
Writing output to: /var/www/data/a7320b6c-bee6-4f4e-a986-ab048f6e4124/odm_texturing/odm_textured_model_geo.obj
Log file path was set to: /var/www/data/a7320b6c-bee6-4f4e-a986-ab048f6e4124/odm_georeferencing/odm_georeferencing_log.txt
Transform file path was set to: /var/www/data/a7320b6c-bee6-4f4e-a986-ab048f6e4124/odm_georeferencing/odm_georeferencing_transform.txt
Georef file output path is set to: /var/www/data/a7320b6c-bee6-4f4e-a986-ab048f6e4124/odm_georeferencing/odm_georeferencing_model_geo.txt

Missing input in order to use GCP for georeferencing. Using EXIF data instead.

Reading mesh file…
… mesh file read.

Applying transform to mesh…
… mesh transformed.

Successfully saved model.

Saving final transform file to ‘/var/www/data/a7320b6c-bee6-4f4e-a986-ab048f6e4124/odm_georeferencing/odm_georeferencing_transform.txt’…
… final transform saved.

Saving georeference system file to ‘/var/www/data/a7320b6c-bee6-4f4e-a986-ab048f6e4124/odm_georeferencing/odm_georeferencing_model_geo.txt’…
… georeference system saved.

1 Like

From Drone & UAV Mapping Software | WebODM, download the results (the all.zip file). Is the entwine_pointcloud folder in there?

If not, you probably didn’t send the task from WebODM (the Desktop app). If you uploaded the task manually from the webodm.net dashboard, you need to check the generate 2D and potree point cloud tiles option before processing in order to generate the entwine_pointcloud folder.

That’s my guess as to why the 3D model might be missing from display.

You can still drop the odm_georeferenced_model.laz file into https://plas.io to display it.


This makes sense… and appears to be the reason the model is missing. I should have paid more attention to the settings before I ran the task. Appreciate all your help.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.