WebODM Seems to Hang Compressing All.zip


#1

Running WebODM has been running great until I started adding GCP. It Appears to finish Processing
Postprocessing:Done Then seem to hang for hours Compressing All.zip.
If I run the same options without GCP file it completes. Have not had this happen on any other tasks or projects using GCP,
My Operating system is Windows 10 PRO. Webodm using Docker. 16 GB Ram, Intel I7.
Looking for direction.
Thanks for any help you may provide


#2

@VDS have you configured docker to use more memory? It’s likely that this is a problem caused by low memory.


#3

Yes I upped the memory to 12gis, increased processors, increased swap and vd size. Still hangs.
I did change the projection format in the GCP file from
EPSG:3605 (+proj=lcc +lat_1=49 +lat_2=45 +lat_0=44.25 +lon_0=-109.5 +x_0=599999.9999976 +y_0=0 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +to_meter=0.3048 +no_defs )
to
EPSG:2256 (+proj=lcc +lat_1=49 +lat_2=45 +lat_0=44.25 +lon_0=-109.5 +x_0=599999.9999976 +y_0=0 +ellps=GRS80 +datum=NAD83 +to_meter=0.3048 +no_defs )
and it worked. The point cloud and ortho did not have the correct geo-positioning but i was able to use in in my earthwork files after a rotation. Made it work but would like to figure it out so I don’t have to repeat it again.
Thanks for any help or direction you can provide.


#4

Mm, strange. Could you share the images and GCP file you used, as well as the preset information you used for processing? You can use Google Drive / Dropbox to share the images and GCP file.


#5

Images and GCP Files have been uploaded to gogledrive see link below.

https://drive.google.com/open?id=1peLwR6nrGWjqDXOU198YTY_sTsaxJ7Oz

File Names:

Drone 1 Field Survey 100-105.txt (Ascii text file field survey ground control points) (MT State Plane NAD83-2007)

gcp_file_100-105.txt (Ascii text file Modified header to EPSG:2256 ((http://spatialreference.org/ref/epsg/2256/) This on Completes but wrong geo-location for Orthophotp and point cloud but good coordinate calculation for import to CAD with no Projection)

gcp_file_EPSG3605 100-105.txt (Ascii text GCP file EPSG:3605 (((http://spatialreference.org/ref/epsg/3605/) This on Does not Complete Hangs on compressing All.zip.

Phantom 4 Pro Images (Compressed zip folder containing Images) Sorry for all the images on a small site but I have elevation restriction in the project area.

The Control point coordinates were collected by Topcon Hiper Lite survey grade. Project was localized. Horizontal and vertical error at time of field survey of GCP was less than ±0.05

Survey ground control points were exported to ascii text file and the header line was added for projection (EPSG:3605 (+proj=lcc +lat_1=49 +lat_2=45 +lat_0=44.25 +lon_0=-109.5 +x_0=599999.9999976 +y_0=0 +ellps=GRS80 +towgs84=0,0,0,0,0,0,0 +to_meter=0.3048 +no_defs ) Reference website (http://spatialreference.org/ref/epsg/3605/)

Then I used the GCP WebODM interface to make the GCP file

Used Default Fast Orthophoto with resize image 2048. Did not complete processing hang at compressing all.zip 10hrs plus

Then I used Fast Orthophoto with resize image 2048 no GCP and completed 1hr 22Min.

Did some reading and changed the Header file and renamed the GCP file to gcp_file_100-105.txt Header projection changed to (EPSG:2256 +proj=lcc +lat_1=49 +lat_2=45 +lat_0=44.25 +lon_0=-109.5 +x_0=599999.9999976 +y_0=0 +ellps=GRS80 +datum=NAD83 +to_meter=0.3048 +no_defs) and it worked geo-location not good but coordinates of point cloud and ortho image insert into CAD with no projections and match other field survey data. good for today but leaves me wondering what I’m doing wrong.

Thanks for the Help

any other questions please contact me.

Once again Thanks for the Help.


#6

Hi! I have the same problem. When i use photos from Phantom 4 Pro without GCP all is ok, but when i add GCP file WebODM not finish task. It create ‘assets’ directory of task with all products (ortophoto, pointcloud, etc.) then delete ‘assets’ directory of task and create it again with all products (ortophoto, pointcloud, etc.) then again delete ‘assets’ directory and it stuck in this infinity loop. When i cancel task the ‘assets’ directory of task with all products (ortophoto, pointcloud, etc.) is available on WebODM data directory (i use ‘–media-dir’ parameter) but it’s unavailable via WebODM interface because task status is ‘cancelled’.
I use EPSG:2178. The header of GCP file:
+proj=tmerc +lat_0=0 +lon_0=21 +k=0.999923 +x_0=7500000 +y_0=0 +ellps=GRS80 +units=m +no_defs