WebODM Installer - Windows 10


#1

Purchased the ‘Standard’ Installer for WebODM in hopes of finding an alternative to Pix4D, DroneDeploy, etc. for processing fairly small projects for GeoTIFF and LAS outputs. Have some experience successfully installing and using other open source software, but running to a road block here. Could be user error, I’m defiantly not advanced, hence the reason I purchased the installer.

  • Computer checks out for all requirements
  • Followed the supplied documentation
  • Get an error in the WebODM Manager when trying to initiate the application: (webodm) Waiting for an IP…
    Too many retries waiting for SSH to be available. Last error: Maximum number of retries (60) exceeded
    Could not start virtual machine
  • From VirtualBox, I get this Error when I try to start the VM: Callee RC: E_FAIL (0x88004005)
  • If I run VirtualBox as Administrator it starts
  • I’ve tried running the whole install as Administrator and under the Administrator account, same results
  • Searched this forum / github / etc. but haven’t had luck with any of the suggested workarounds.

Any help would be appreciated, would love to get this product running and see how it compares to others.

Thanks!


#2

Hey @jeffk428, this looks like the same problem reported here due to a recent Windows Update: Cannot open WebODM

I have fixed this problem just today and released a newer version (1.5.6) of the WebODM Manager program. I’ve sent you a private message about that. I’m guessing you are running 1.5.5. If you update to 1.5.6, then press the “Delete VM” button from the maintenance panel and restart the program, things should work. If they don’t, please let me know?

Thanks!


#3

@pierotofy I have the same issue - where can i update to 1.5.6?


#4

@bochen pm sent! :+1:


#5

I have the same issue except using WebODM installer (version 1.5.5) on Win 7 Pro 64 bit machine.


#6

@DocBird Message me your purchase order # and I’ll send you the updated version.


#7

Sent. Thanks


#8

Pm sent! :ok_hand:


#9

I too have the same issue, Windows 10 Home machine


#10

I’ve replied to your message via e-mail @markon.


#11

Thank you very much pierotofy :smiley:


#12

Hi Piero,

I am facing the same problem. I am using version 1.3.0

will it give the same problem?


#13

Sent you an e-mail @cwg18.


#14

Hi piero,

Used the newer installer and now it gives me this message

Status: Downloaded newer image for opendronemap/webodm_db:latest
Pulling node-odm-1 (opendronemap/node-opendronemap:)…
latest: Pulling from opendronemap/node-opendronemap
unauthorized: authentication required
C:\WebODM Manager\WebODM>exit 1
Error: docker-compose exited with code: 1

What kind of authentication is needed and where do I key it in?


#15

That’s odd, you shouldn’t need any authentication. Could you try to uninstall the docker application, then re-run the WebODM setup? Also, you could try to press the white whale icon from the task tray and press the “Sign-out” button if you happen to be logged in.


#16

I´ve got the same issue (1.5.3) after I had to Delete VM after problems running docker/webodm…


#17

I’ve sent you an e-mail @Darne :+1:


#18

Thanx!