Warping of trees and buildings

optimization

#1

I am doing orthophoto work - vegetation and geology work - and have managed to get my images pretty good now. I am still having a few issues with warping of trees and buildings. I changed the mesh octree depth to 6 then 3, then 1 and finally got images that were a lot less warped around the trees. any suggestions to help would be greatly appreciated.

Other settings:
Fast orthophoto on
min num features 50000

I have included two snapshots from on of my images to show what I mean.

Thanks for any help you can provide :slight_smile:
odm_orthophoto_cropped_02


#2

Hi All,

So I have been looking at why my data was doing what it did. It took me a while, but I realised that the data had big gaps. It was in the gaps that the warping was occurring.

I looked at my flight lines and realised that my drone had skipped lines in some areas (about to mail developer about this). The warping was resulting from a less than 60% overlap.

In my most recent processing I managed to get only a handful of trees warping by adding in some infill photographs from a previous flight. My minum features were set to 20000 fast orthophoto was on and mesh-octree was 6, so it clearly has less to do with the settings than the photo density.

I will re-run my flight when I get a chance and increase the overlap of images so that I will have a 60% overlap if my drone misses lines and I will post back with results. I hope this information will help people that have the same kind of issue that I have had.


#3

Excellent, @Pat. Keep us updated. There’s also some work underway the next few weeks to improve orthophotos, so it will be interesting to see how much that helps as well.