Partial othrophoto creation


#1

From @glw on Wed Mar 07 2018 21:14:52 GMT+0000 (UTC)

Im getting a similar output as issue #491 . Where my total AOI is not included in the final orthophoto.
Im using the docker version

docker run -it --rm -v $(pwd):/code/images -v $(pwd)/odm_orthophoto:/code/odm_orthophoto -v $(pwd)/odm_texturing:/code/odm_texturing opendronemap/opendronemap --fast-orthophoto

here are my results:
image

The points are the exif locations of my imagery.

My overlap should have been somewhere around 80/80 or 85/85. Camera is Parrot Sequoia and Im only running the RGB images at the moment.

I saw in the previous issue, he had tweaked the --min_num_features , is this still the recommended route?

Thanks!

Copied from original issue: https://github.com/OpenDroneMap/OpenDroneMap/issues/779


#2

From @smathermather on Fri Mar 16 2018 17:08:25 GMT+0000 (UTC)

@glw – did you calibrate your parrot images? My hunch is barrel distortion is causing issues in the matching. @dakotabenjamin has a set of scripts for addressing this at https://github.com/OpenDroneMap/CameraCalibration


#3

Hmmm. I just went thru the calibration steps and then re-ran the new images, and am getting a similar output. Im going to test it on another set of images and see what happens.


#4

I had the same problem. I changed the crop to 0, and I got my results.


#5

How much overlap did you have for your images?


#6

70-80% max


#7

@glw what’s the terrain / vegetation like in your AOI? I’m curious if the scene might be noisy and causing reconstruction problems.


#8

hi @dakotabenjamin, its pretty flat, but highly vegetated. Im wondering if the overlap I programmed into the drone flight app was ignored for what is in the sequoia’s camera settings.


#9

Just wanted to report back that I had a successful run on another flight. I think my hunch on the overlap being incorrect was correct.