Ortophoto quality


#1

Hello,
I just tested latest commit from master. I built sources on my ubuntu machine. After processing I found that roofs of buildings has strange wavy effects (see attachment). I used these parameters:
–min-num-features: 25000
–orthophoto-resolution: 0.001
–force-ccd: 13.1
How can I fix this? Thanks in advance.
45484047-0ce61380-b77d-11e8-859a-2a1b6c7acfac


#2

Do you get better results if you increase --mesh-octree-depth to 9 or 10? Also try to increase --texturing-nadir-weight to 24-32.


#3

I added as you said. Here is my final list of parameters:
–min-num-features: 25000
–orthophoto-resolution: 0.001
–force-ccd: 13.1
–mesh-octree-depth: 10
–texturing-nadir-weight: 32
But issue still persist (even it became worse, I think):
example

Also, how I should pass ‘texturing-nadir-weight’ parameter? I passed it to run.sh script. May be I should add it to the ‘settings.yaml’ file?


#4

The parameter is fine passed through the command line. What if you also try to increase depthmap-resolution to something like 1000?

Edit: also see if adding --use-3dmesh improves the output.


#5

Hello,
Sorry for late answer, I had no possibility to test it again. I made several tests, when I used only one of your parameters, when both, but still with no success. My final list of parameters:
–min-num-features: 25000
–orthophoto-resolution: 0.001
–force-ccd: 13.1
–mesh-octree-depth: 10
–texturing-nadir-weight: 32
–depthmap-resolution: 1000
–use-3dmesh
And this is what I got:
img
Also, what happened with my previous images? I can’t understand why my attachments broke.