No geo-referenced orthophoto created due to missing geo-referencing or corner coordinates


#1

Hi everyone,

I’m trying to create the orthophoto from my images, but when it arrive to the step of orthophoto creation it is returning the error in the title “No geo-referenced orthophoto created due to missing geo-referencing or corner coordinates.”

I’m using docker and I launch it with docker run -ti --rm -v /home/lucadelu/drone_data/2018_08_11_lavis_orto/odm_wgs84_25dmesh:/datasets/code opendronemap/opendronemap --project-path /datasets --use-25dmesh --orthophoto-bigtiff=YES --build-overviews --min-num-features 10000

My gcp_list.txt is in /home/lucadelu/drone_data/2018_08_11_lavis_orto/odm_wgs84_25dmesh/images/ and it is like the following lines

+proj=longlat +datum=WGS84 +no_defs
11.103192807508 46.1402260655751 215 2119 733 2018_0911_122021_082.JPG
11.103192807508 46.1402260655751 215 1982 1602 2018_0911_122026_084.JPG
11.103192807508 46.1402260655751 215 1957 1940 2018_0911_122031_086.JPG
11.103192807508 46.1402260655751 215 1862 3246 2018_0911_122035_088.JPG
11.103192807508 46.1402260655751 215 1265 829 2018_0911_122156_120.JPG
11.103192807508 46.1402260655751 215 874 1742 2018_0911_122201_122.JPG
11.103192807508 46.1402260655751 215 1069 2569 2018_0911_122206_124.JPG
11.1033256140575 46.1401388920927 215 3928 1166 2018_0911_122350_166.JPG

#2

I don’t see anything wrong, the command is correct and so is the GCP file.

Perhaps it has to do with the SRS in the GCP file. Could you copy/paste the output of your task? Something to try also is to see if it works if you specify your coordinates using a UTM reference system instead of lat/lon. If that’s the cause, this is a bug and we should open an issue on GitHub.


#3

I also tried with UTM coordinates but I got the same error, this is the log of orthophoto with WGS84

Arguments given
-inputFile
/datasets/code/odm_texturing_25d/odm_textured_model_geo.obj
-logFile
/datasets/code/odm_orthophoto/odm_orthophoto_log.txt
-outputFile
/datasets/code/odm_orthophoto/odm_orthophoto.png
-resolution
20.0
-outputCornerFile
/datasets/code/odm_orthophoto/odm_orthophoto_corners.txt

Reading textured mesh from: /datasets/code/odm_texturing_25d/odm_textured_model_geo.obj
Log file path was set to: /datasets/code/odm_orthophoto/odm_orthophoto_log.txt
Writing output to: /datasets/code/odm_orthophoto/odm_orthophoto.png
Resolution count was set to: 20pixels/meter
Writing corners to: /datasets/code/odm_orthophoto/odm_orthophoto_corners.txt

Reading mesh file...
.. mesh file read.

Number of faces in the model 178851
Set boundary to contain entire model.
Local boundary points:
Point 1: -238.235 -209.543
Point 2: -238.235 187.155
Point 3: 248.809 187.155
Point 4: 248.809 -209.543

Ortho photo bounds x : -238.235 -> 248.809
Ortho photo bounds y : -209.543 -> 187.155
Ortho photo area : 193209m2
Ortho photo resolution, width x height : 9741x7934
Translating and scaling mesh...
.. mesh translated and scaled.

Rendering the ortho photo...
Material 0 rendered.
Material 1 rendered.
Material 2 rendered.
Material 3 rendered.
Material 4 rendered.
Material 5 rendered.
Material 6 rendered.
Material 7 rendered.
Material 8 rendered.
Material 9 rendered.
Material 10 rendered.
Material 11 rendered.
Material 12 rendered.
Material 13 rendered.
Material 14 rendered.
Material 15 rendered.
Material 16 rendered.
...ortho photo rendered

Writing ortho photo to /datasets/code/odm_orthophoto/odm_orthophoto.png
Writing corner coordinates to /datasets/code/odm_orthophoto/odm_orthophoto_corners.txt
Orthophoto generation done.

Can I try something different?


#4

Sorry, what I meant to ask was for a copy of the entire output as shown in the terminal when processing your dataset, not just the output of the odm_orthophoto program.


#5

So, I run the first time with DSM flag and it returned me an error on pdal pipeline

root@lucalaptop:/home/lucadelu/drone_data/2018_08_11_lavis_orto# docker run -ti --rm -v /home/lucadelu/drone_data/2018_08_11_lavis_orto/odm_wgs84_25dmesh:/datasets/code  opendronemap/opendronemap --project-path /datasets --use-25dmesh --orthophoto-bigtiff=YES --build-overviews --min-num-features 10000 --dsm --rerun-from odm_dem
[INFO]    Initializing OpenDroneMap app - Thu Aug 16 06:43:31  2018
[INFO]    Running ODM Load Dataset Cell
[DEBUG]   Loading dataset from: /datasets/code/images
[DEBUG]   /datasets/code/images
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122945_308.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122526_204.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122951_310.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122500_194.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122040_090.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122541_210.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122455_192.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122440_186.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122035_088.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122230_134.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122636_232.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122531_206.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122340_162.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122931_302.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122126_108.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122356_168.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122136_112.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122445_188.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122626_228.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122301_146.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122056_096.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123001_314.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122556_216.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122936_304.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122806_268.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122201_122.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122256_144.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_121950_070.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122536_208.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122611_222.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123021_322.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122021_082.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123121_346.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122716_248.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123026_324.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122856_288.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122431_182.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122306_148.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123016_320.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122821_274.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122236_136.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122251_142.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122655_240.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122646_236.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122631_230.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122121_106.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122600_218.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122926_300.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122735_256.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122051_094.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122546_212.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123100_338.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123055_336.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122436_184.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122750_262.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122840_282.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122401_170.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122206_124.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122005_076.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122156_120.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122045_092.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122215_128.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122416_176.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122641_234.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123031_326.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122330_158.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122851_286.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122725_252.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122616_224.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122111_102.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122350_166.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122650_238.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122516_200.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122911_294.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122106_100.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123106_340.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122801_266.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122345_164.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122311_150.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122115_104.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122240_138.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122846_284.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122941_306.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122151_118.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122026_084.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123040_330.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122016_080.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122326_156.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122746_260.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122225_132.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122101_098.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122836_280.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[INFO]    Found 140 usable images
[DEBUG]   Line: +proj=longlat +datum=WGS84 +no_defs
[INFO]    Running ODM Load Dataset Cell - Finished
[INFO]    Running ODM OpenSfM Cell
[WARNING] Found a valid OpenSfM reconstruction file in: /datasets/code/opensfm/reconstruction.json
[WARNING] Found a valid Bundler file in: /datasets/code/opensfm/reconstruction.json
[DEBUG]   running PYTHONPATH=/code/SuperBuild/install/lib/python2.7/dist-packages /code/SuperBuild/src/opensfm/bin/opensfm export_geocoords /datasets/code/opensfm --transformation --proj '+units=m +proj=longlat +datum=WGS84 +no_defs'
[INFO]    Running ODM OpenSfM Cell - Finished
[INFO]    Running ODM Meshing Cell
[WARNING] Found a valid ODM Mesh file in: /datasets/code/odm_meshing/odm_mesh.ply
[WARNING] Found a valid ODM 2.5D Mesh file in: /datasets/code/odm_meshing/odm_25dmesh.ply
[INFO]    Running ODM Meshing Cell - Finished
[INFO]    Running MVS Texturing Cell
[WARNING] Found a valid ODM Texture file in: /datasets/code/odm_texturing/odm_textured_model.obj
[WARNING] Found a valid ODM Texture file in: /datasets/code/odm_texturing_25d/odm_textured_model.obj
[INFO]    Running ODM Texturing Cell - Finished
[INFO]    Running ODM Georeferencing Cell
[WARNING] Found a valid georeferenced model in: /datasets/code/odm_25dgeoreferencing/odm_georeferenced_model.ply
[INFO]    Running ODM Georeferencing Cell - Finished
[INFO]    Running ODM DEM Cell
[INFO]    Classify: False
[INFO]    Create DSM: True
[INFO]    Create DTM: False
[INFO]    DEM input file /datasets/code/odm_georeferencing/odm_georeferenced_model.las found: True
[INFO]    Creating ../datasets/code/odm_dem/dsm_r0.1 [idw] from 1 files
[DEBUG]   running pdal pipeline -i /tmp/tmpjjLSir.json > /dev/null 2>&1
[INFO]    Completed ../datasets/code/odm_dem/dsm_r0.1 [idw] in 0:00:11.046369
[INFO]    Creating ../datasets/code/odm_dem/dsm_r0.3 [idw] from 1 files
[DEBUG]   running pdal pipeline -i /tmp/tmpgAn6np.json > /dev/null 2>&1
[INFO]    Completed ../datasets/code/odm_dem/dsm_r0.3 [idw] in 0:00:13.224516
[INFO]    Creating ../datasets/code/odm_dem/dsm_r0.9 [idw] from 1 files
[DEBUG]   running pdal pipeline -i /tmp/tmpVb2u3J.json > /dev/null 2>&1
[INFO]    Completed ../datasets/code/odm_dem/dsm_r0.9 [idw] in 0:00:10.532736
[INFO]    Creating ../datasets/code/odm_dem/dsm_r2.7 [idw] from 1 files
[DEBUG]   running pdal pipeline -i /tmp/tmptnwgWL.json > /dev/null 2>&1
[INFO]    Completed ../datasets/code/odm_dem/dsm_r2.7 [idw] in 0:00:12.824809
Traceback (most recent call last):
  File "/code/run.py", line 47, in <module>
    plasm.execute(niter=1)
  File "/code/scripts/odm_dem.py", line 108, in process
    verbose=args.verbose
  File "/code/opendm/dem/commands.py", line 45, in create_dems
    gap_fill(fouts[product], fout)
  File "/code/opendm/dem/commands.py", line 115, in gap_fill
    arr[badlocs] = griddata(goodlocs, arr[goodlocs], badlocs, method=interpolation)
  File "/usr/local/lib/python2.7/dist-packages/scipy/interpolate/ndgriddata.py", line 210, in griddata
    fill_value=fill_value)
  File "/usr/local/lib/python2.7/dist-packages/scipy/interpolate/interpolate.py", line 528, in __init__
    "least %d entries" % minval)
ValueError: x and y arrays must have at least 2 entries

#6

At this point I run it again without --dsm flag and this time it ended but without the orthophoto (it just created a png file, that I georeferenced with GRASS GIS) this the full log

root@lucalaptop:/home/lucadelu/drone_data/2018_08_11_lavis_orto# docker run -ti --rm -v /home/lucadelu/drone_data/2018_08_11_lavis_orto/odm_wgs84_25dmesh:/datasets/code  opendronemap/opendronemap --project-path /datasets --use-25dmesh --orthophoto-bigtiff=YES --build-overviews --min-num-features 10000 --rerun-from odm_dem
[INFO]    Initializing OpenDroneMap app - Thu Aug 16 06:47:07  2018
[INFO]    Running ODM Load Dataset Cell
[DEBUG]   Loading dataset from: /datasets/code/images
[DEBUG]   /datasets/code/images
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122945_308.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122941_306.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122151_118.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123006_316.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122741_258.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123116_344.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123045_332.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122730_254.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123011_318.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123050_334.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122811_270.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122010_078.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123036_328.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122406_172.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122720_250.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122335_160.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122521_202.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122756_264.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122450_190.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122505_196.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123125_348.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122815_272.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122621_226.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122901_290.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122411_174.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122316_152.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122001_074.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122421_178.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122426_180.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122830_278.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122141_114.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122550_214.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_121955_072.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122905_292.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122711_246.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122211_126.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122706_244.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122956_312.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123111_342.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122606_220.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122031_086.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122916_296.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122220_130.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122026_084.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_123040_330.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122016_080.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122326_156.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122746_260.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122225_132.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122321_154.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122146_116.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122921_298.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122700_242.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122825_276.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122246_140.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122511_198.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122131_110.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122101_098.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[WARNING] Could not find ccd_width in file. Use --force-ccd or edit the sensor_data.json file to manually input ccd width
[DEBUG]   Loaded 2018_0911_122836_280.JPG | camera: mapir camera survey2_rgb | dimensions: 4608 x 3456 | focal: 4.0 | ccd: None | lat: None | lon: None | alt: None
[INFO]    Found 140 usable images
[DEBUG]   Line: +proj=longlat +datum=WGS84 +no_defs
[INFO]    Running ODM Load Dataset Cell - Finished
[INFO]    Running ODM OpenSfM Cell
[WARNING] Found a valid OpenSfM reconstruction file in: /datasets/code/opensfm/reconstruction.json
[WARNING] Found a valid Bundler file in: /datasets/code/opensfm/reconstruction.json
[DEBUG]   running PYTHONPATH=/code/SuperBuild/install/lib/python2.7/dist-packages /code/SuperBuild/src/opensfm/bin/opensfm export_geocoords /datasets/code/opensfm --transformation --proj '+units=m +proj=longlat +datum=WGS84 +no_defs'
[INFO]    Running ODM OpenSfM Cell - Finished
[INFO]    Running ODM Meshing Cell
[WARNING] Found a valid ODM Mesh file in: /datasets/code/odm_meshing/odm_mesh.ply
[WARNING] Found a valid ODM 2.5D Mesh file in: /datasets/code/odm_meshing/odm_25dmesh.ply
[INFO]    Running ODM Meshing Cell - Finished
[INFO]    Running MVS Texturing Cell
[WARNING] Found a valid ODM Texture file in: /datasets/code/odm_texturing/odm_textured_model.obj
[WARNING] Found a valid ODM Texture file in: /datasets/code/odm_texturing_25d/odm_textured_model.obj
[INFO]    Running ODM Texturing Cell - Finished
[INFO]    Running ODM Georeferencing Cell
[WARNING] Found a valid georeferenced model in: /datasets/code/odm_25dgeoreferencing/odm_georeferenced_model.ply
[INFO]    Running ODM Georeferencing Cell - Finished
[INFO]    Running ODM DEM Cell
[INFO]    Classify: False
[INFO]    Create DSM: False
[INFO]    Create DTM: False
[INFO]    DEM input file /datasets/code/odm_georeferencing/odm_georeferenced_model.las found: True
[WARNING] DEM will not be generated
[INFO]    Running ODM DEM Cell - Finished
[INFO]    Running ODM Orthophoto Cell
[DEBUG]   running /code/build/bin/odm_orthophoto -inputFile /datasets/code/odm_texturing_25d/odm_textured_model_geo.obj -logFile /datasets/code/odm_orthophoto/odm_orthophoto_log.txt -outputFile /datasets/code/odm_orthophoto/odm_orthophoto.png -resolution 20.0  -outputCornerFile /datasets/code/odm_orthophoto/odm_orthophoto_corners.txt
[WARNING] No geo-referenced orthophoto created due to missing geo-referencing or corner coordinates.
[INFO]    Running ODM OrthoPhoto Cell - Finished
[INFO]    OpenDroneMap app finished - Thu Aug 16 06:48:36  2018

#7

I suspect this is could be the trouble line: /code/SuperBuild/install/lib/python2.7/dist-packages /code/SuperBuild/src/opensfm/bin/opensfm export_geocoords /datasets/code/opensfm --transformation --proj '+units=m +proj=longlat +datum=WGS84 +no_defs'

But it looks like it’s still trying to use longlat, not UTM. You mentioned you tried with UTM? Did you reprocess the dataset with the UTM coordinates or just replaced the gcp_list.txt file? Try to start from a fresh directory.

The odm_georeferencing_model_geo.txt file might have some clues as to why this is not working, but I suspect that non-UTM projections are currently giving some issues and we should fix it.