Export las instead of laz


#1

Hi all,

I have installed and start to use WebODM.
I have successfully generate the results. But in my version of WebODM I cannot export point cloud in las format. It only has an option to export point clouds as laz.
As I have seen in the [1] YouTube video it has a function to export as las.
If current version of WebODM doesn’t support for exporting las file, please kindly suggest me a method to convert laz to las.
Note that I am using Ubuntu 16.04.

[1] https://www.youtube.com/watch?v=0zVtZxWyBsw

Thank you!


#2

Hey @nsl you can use pdal translate to convert laz to las. https://pdal.io/


#3

Thank you for your @pierotofy suggestion.
I have tried with following command but I was not succeeded

docker run pdal/pdal:1.7 pdal translate input.laz output.las

It always says it cannot find the input file, even it is in the same name and the right directory.

Please kindly help me to convert laz to las.
Thank you for your valuable suggestions.

Thank you!


#4

You’ll need to mount a volume (using the -v or --volume parameter) to read/write files with docker. See https://pdal.io/quickstart.html for some examples.


#5

Thank you for your @pierotofy reply.

Yes, I run that way too.

docker run -v /Users/user/Documents/odm:/Result pdal/pdal:1.7 pdal translate Result/input.laz Result/output.las

Please kindly let me know what was the problem.
Thank you very much!


#6

Perhaps try with:

docker run -v /Users/user/Documents/odm:/Result pdal/pdal:1.7 pdal translate /Result/input.laz /Result/output.las

#7

Thank you @pierotofy

No, it was not succeeded.
It complains that

PDAL: Unable to open stream for ‘/Result/input.laz’ with error ‘No such file or directory’

But, I can confirm you that, my file name is input.laz and the file is in ‘/Users/user/Documents/odm/Result’ directory.

Thank you for your time.


#8

Perhaps you haven’t setup docker to mount volumes properly? See http://www.sortedset.com/getting-started-with-docker-in-windows-with-volumes-and-virtualbox-shared-folder/

Otherwise I’m not sure. Perhaps you could ask the PDAL community? https://pdal.io/community.html


#9

Thank you very much @pierotofy
I will move to PDAL community.

Thanks you!


#10

http://www.cs.unc.edu/~isenburg/lastools/
Search for laszip.exe on this site. I’ve had good luck with it.

Cheers