Building/Running ODM on Ubuntu 16.04 not working


#1

From @rionlerm on Wed Nov 15 2017 13:52:48 GMT+0000 (UTC)

Hi guys am I doing something wrong here?

I passed bash configure.sh reinstall and followed the Readme instructions to run ODM.

ODM is installed on removable media and ENVs are set to an empty directory (path to project) on the Desktop,

When I pass ./run.sh odm_data_aukerman (the data dir. with images folder is inside the Desktop projects path as a sub-directory) the Terminal tells me: bash: ./run.sh: Permission denied

If I add bash in front of the above command: ImportError: No module named ecto pops up. This error also popped up when I accidentally passed python run.py... on my version of Ubuntu.

What could be the problem?

Copied from original issue: https://github.com/OpenDroneMap/OpenDroneMap/issues/712


#2

From @Wes-Skeeter on Fri Nov 24 2017 22:29:15 GMT+0000 (UTC)

Why did you run reinstall instead of install, did you have a previous version working at some point? Have you tried running sudo ./run.sh ?


#3

From @dakotabenjamin on Tue Nov 28 2017 16:02:14 GMT+0000 (UTC)

Do you normally run on removable media? You may have to make sure that the user logged into the computer you are running from has permission to run run.sh

You can check permissions with ls -l


#4

From @rionlerm on Wed Dec 06 2017 08:01:53 GMT+0000 (UTC)

@Wes-Skeeter I had a previous version working. Passing sudo run.sh or bash run.sh the missing ecto error pops up.

@dakotabenjamin I normally don’t run on removable media, but even after copying the ODM folder to Desktop this common problem re-occurs:

screenshot from 2017-12-06 10-01-29
Here is the projects folder with path specified in ENV after passing gedit ~/.bashrc:
screenshot from 2017-12-06 10-12-53


#5

From @rionlerm on Thu Dec 07 2017 08:57:51 GMT+0000 (UTC)

@dakotabenjamin something that might point you in the right direction towards a solution. When running bash configure.sh reinstall from Desktop I noticed this:

screenshot from 2017-12-07 10-55-56


#6

From @rionlerm on Thu Dec 07 2017 09:24:52 GMT+0000 (UTC)

Is this possibly related to Issue #217?


#7

Hi @dakotabenjamin,

I am taking this issue up again as I need to do some UAV work next week.

So I reloaded Ubuntu 16.04 on my Core i7 Processor with 12GB RAM.

I passed bash configure.sh install and performed two reinstall.

However, as before: ImportError: No module named ecto when performing the python run.

Our office bandwidth is low (~3Mbps download and ~2Mbps upload) and when passing:

cd Superbuild/build
cmake ..
make -j1

PCL doesn’t build:
image

Shall I attempt a faster bandwidth line on my side with the install?


#8

Safest thing to do is download this from the browser: https://github.com/PointCloudLibrary/pcl/archive/pcl-1.8.0.tar.gz

then copy/move it to SuperBuild/download and run ./configure.sh install 1


Building on Ubuntu 16.04
#9

image

?


#10

Finally, the script is running!

I passed:

./configure.sh reinstall
./configure.sh install 1

the latter run after I downloaded the latest PCL version in tar.gz format as specified above and added to ..Superbuild/downloads folder

Redid my settings.yaml file and ran with the project images in the project directory…viola!

I still suspect the issue was my slow bandwidth at the office.

Thanks for everyone’s help and patience…now Africa is back on track again.