3D Model Quality


#1

Hi @pierotofy,
I processed the Pix4D building example for a QA/QC comparison wth webODM. I used the following settings: 3D MODELLING

  • mesh-solver-divide - 10
  • mesh-octree-depth - 10
  • min-num-features - 12,000
  • orthophoto-resolution - 60
  • complexNonForest
  • texturing-data-term - area
  • opensfm0depthmap-resolution - 800
  • use-pmvs - Enable

For better results I tried updating the following as per your suggestion in another dicussion board. opensfm0depthmap-resolution - 1,200, & Depth-method - Brute force

Curious if you have any recommendations to improve the output. Based on the comments in other discussion boards, there is a lack of in-fill along the vertical axis is due to ODM limitations properly aligning and blend the oblique imagery. Curious if there is an update in the pipeline to resolve this. Look forward to hearing from you soon.

Kind Regards,
Pix4D webODM


#2

Yes, expect improvements all-around in the very near future, including for 3D models output. See https://www.opendronemap.org/2018/07/repost-upcoming-improvements-to-opendronemap-better-everything/


#3

Have you tried viewing your OBJ in a different viewer too?
I had an issue where my results had a scrunched up paper effect on them, like your road, but it turned out to be a shading effect the built in viewer ads by default.
The result looked a lot better in something like Meshlab.


#4

I’m having a similar issue, but I’m using ODM on Docker. My main concern is the ‘bubble’ effect around poles and power lines (see below). How do you stop that from happening?
My Settings:

  • resolution 100
  • opensfm-depthmap-resolution 1280
  • everything else is default

04%20AM


#5

@spifftek70,
I’m not sure how you would fix that. Maybe try the “ComplexNonForest” similar settings as above. Quite possible you didn’t capture enough angles, which is causing the issue.

@pierotofy What settings can I use to reduce the vector look of my 3D model? I tried to increase the min number of features (12,000), ortho resolution (60m), and FlatForest, but neither worked? Is there a way to increase the point cloud density to smooth-out the ground surface? I noticed above that you’re releasing an update fro 3D modelling. will i need to update my server for these to be updated? Would I be able to get your help?